Peripheral Support In Spintires: MudRunner

Same result there, and it doesn't appear among the other devices again.

@lombra Thanks again for the feedback, I really appreciate!
So there is hope to make it work after all 😄 There must be something I didn't set up right. I'll take another look into the game to find out. I'll keep you updated if I find anything.

Meant to ask, do you use Steam input configuration? I'm not sure whether I do actually, and can't check now, but I think I do not. Any other controllers plugged in or something?

You mean the menu in Big Picture? I do not use it, but I tried once for Spintires and it didn't change anything. But since it was the first time I was opening it, I may not have done things right.
I have a Xbox controller plugged in, but I don't switch it on when I'm using the wheel/F710.

I give up.

I reset the controls, tried with and without X360 Controller Emulator, but nothing works. When I accelerate (with the F710 controller), the wheels go straight, even if I keep steering with the G27. And when I lift off, the wheels turn all of a sudden (the way they should).

And it's exactly the same with an original Xbox One controller.

The fact that it works for you puzzles me. There is almost no in-game settings for the controllers, except the key binding for the wheel. What did I miss?

What's your OS and which version of Logitech Gaming Software do you use?

Maybe you could try using Steam input, and disable the steering joystick on your controller for Mudrunner. I think that should be possible, at least.

Windows 10 and LGS 5.10.
Everybody is up-to-date and working fine with every other sim game.

When I set up the controls through Steam Input, the wheel is not detected anymore in the game (only the controller). I ticked the "Xbox" and "genreric" controller boxes (seprately and together) in the global Big Picture menu ; then I activated the specific controller settings for the game ; and finally I switched to the "global setting" (both for the Xbox and generic controller). Nothing works.

I disabled all joysticks and even the D-pad in Steam Input. I had also done that with X360 Controller Emulator.

Maybe if I could unassign the throttle/brake control under the "wheel" tab in Mudrunner? It doesn't seem possible.

The logitech g29 does NOT work for ps4 on spintire mudrunner. It will work for every other game, you can go to the controls menu and select the shifter/manual gearbox and it will say steering wheel detected but it will NOT work. No buttons will press nothing works at all. The game is not compatible.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.