Throttle control

So, I was messing around in the game and noticed a bug with my T500RS + TH8A, I can increment the throttle fine when increasing but to decrease the throttle I need to release it then increment it to the desired throttle instead of just reducing the throttle.

Hardware: T500RS Wheel + TH8A Shifter
Mode: Manual with Shifter and Clutch.

For Example: If I am at 80% throttle and need to drop to 50%, I need to release the pedal fully then depress the pedal to 50%.

I can confirm this bug, you can not carefully use the throttle.

T500 Wheel and TH8A Shifter here.

last edited by unixroot

https://forums.focus-home.com/topic/1175/peripheral-support-in-spintires-mudrunner This is the full support hardware, they gonna add more support for the other wheel and shifter later but for now its the list of full supported wheels, its maybe for that you have trouble with your's.

i have same issue with a Logitech G27 w/shifter

I have the same problem with a G27

Odd. A friend and I both have the G27 and have no problems with throttle control in either direction.

@deat said in Throttle control:

So, I was messing around in the game and noticed a bug with my T500RS + TH8A, I can increment the throttle fine when increasing but to decrease the throttle I need to release it then increment it to the desired throttle instead of just reducing the throttle.

Hardware: T500RS Wheel + TH8A Shifter
Mode: Manual with Shifter and Clutch.

For Example: If I am at 80% throttle and need to drop to 50%, I need to release the pedal fully then depress the pedal to 50%.

I also noticed that. It is not only silly but very unrealistic and incredibly annoying!

@k-lisse said in Throttle control:

https://forums.focus-home.com/topic/1175/peripheral-support-in-spintires-mudrunner This is the full support hardware, they gonna add more support for the other wheel and shifter later but for now its the list of full supported wheels, its maybe for that you have trouble with your's.

Playing on g29 which is supported and this bug (or rather mistake in programming) is noticeable and present.

last edited by CoSm1c gAm3r

Just switched to full manual gearbox and then encountered this problem. I was wondering why I'm suddenly using so much fuel and trucks seem to be constantly getting stuck in the mud and easing the throttle does nothing. Well it seems this is the same bug I'm now having. Didn't have this problem before with the simple gearbox. Using a Logitech MOMO Racing Forceback Wheel here.

Having the same issue using my Logitech MoMo on automatic gearbox. Also feels like the throttle has Steps rather than a analouge input. Having linear throttle would be so much better.

I have the same issue here and was about to file a bug report. The throttle Jams to your maximum input until you set the input back to 0. Really strange! Makes it quite difficult to control the trucks without getting stuck.

Using a thrustmaster warthog, with TARGET, but really that's not very relevant. This will be the case with most controllers then (most likely 🙂 )

last edited by bn880

This appears to happen only in the 1, 1+ gears not the A (auto) gear. And while the cruise control is not being pressed on the stick etc.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.