Is the media folder useless?

Is there no way to install a mod by hand anymore? I've seen some mods on the internet but it says you have to put it in the media.zip?! But I don't want to change the .zip as it disables achievements and MP.
I've put a .xml file of the original gaz66 in Media-> classes-> trucks but it does not appear ingame 😕
Does anyone know what happend to the media folder and if we still can install mods that are not from the workshop?

the media folder was uncompressed media.zip
media.zip is still included.
I've done textures but not added any non-workshop trucks.

I know that, but it does not load any data from the media folder anymore, does it?

@dereggen You can install mods just like in the old version. Make a Media folder and add this line in the Config file : <MediaPath Path="Media" />

Thanks! Unfortunately this disables the multiplayer as well. But it's a good advice, much better than messing around with the .zip.

Maybe they can patch the config, so using the <MediaPath Path="Media" /> does only disable the achievments and the multiplayer does not load the media folder but only the default media.zip to stay synchron with other players.

you can add levels to media folder they work online

@shuffy said in Is the media folder useless?:

you can add levels to media folder they work online

How. ?

I tried to place on into the media folder but it disabled MP for me.

try using the media zip like the media folder instead of altering the config. Worth a shot.
..At least that was how I played ALL the maps in tech test instead of just the cple they had unlocked.

Changing files in the media.zip also disables the MP, exchanging and renaming the maps could work, not tried yet.

And because of that, I was very surprised when I saw that there are nearly all maps included in the technical test version.

I've changed the path in the config to the original and now it still shows the mods I have put in the Media folder. Multiplayer is still disabled, I have to rename the Media folder to Media.mod (or whatever you want) and than I can play in multiplayer again.
But 99,9% of the time I play SP and I don't care about the achievements so thanks again for the advices!

I installed a test map the old fashion way only into the zip file. Not sure if the map will actually load though as it is saying I need to pick a truck. I have a truck on the map but it does not appear to see it and therefore wont let me select the map. I am sure I am missing something but no idea what that is yet.

@dereggen said in Is the media folder useless?:

e path in the config to the original and now it still shows the mods I have put in the Media folder. Multiplayer is still disabled, I have to rename the Media folder to Media.mod (or whatever you want) and than I can play in multiplayer again.

so still there is not way to play mod maps in multiplayer right?

how welll like the forest map thats out has two level files copy the to levels zip and it works online me and buddys tested it out with mods

@shuffy haha thanks man, that works well, and im guessing the other map that has all the folders should work the same? i will try and report back. Kinda of a pain in the ass to delete them afterr, but i guess having a backup media zip would do the trick for now 🙂

100 % you can play MP as long as its just the two level files .. obviously they have to be mudrunners ready older spintires maps load but you cannot loads trucks to garage. I have to verify most games so yes a backup is a good idea .. personally i dont think the verify through steam is fixing anything .
Literally the only way i have found of having a stable connection from friends is loading the game up and then inviting friends once the game is loaded.

@shuffy said in Is the media folder useless?:

he only way i have found of having a stable connection from friends is loading the game up and then inviting friends once the game is loaded.

ok tried that and yeah, only levels files work, so if you add anything else , it wont work.

And as far as the connection is concerned, all is fine and dandy here, i usually invite players in the setup screen over there. Worked with 3 players flawlessly every time. Thanks for the help.

@shuffy or were you talking about MP games with addon maps? In which case i will do that yeah, also thanks

since day 1 me and a good 14 people who play with on the game cannot connect without issues wrong map or need to manually inserst stg file ... really annoying

@shuffy hmm weird, i never had problems at all. Interesting, not much i can say really, no ideea what would make that happen

I've figured it out! You need to extract the media.zip into a normal folder and keep it in your game directory alongside the media.zip. Then you need to add the following line to your config file: <MediaPath Path="Media" /> Once you've done that you need to get JSGME which can be downloaded here: https://mega.nz/#!9oQGQLTS!UMfCRwdgsk5hBwqmiYNCzxrxnujcXIIf2_bbm3HfwRo Once you've downloaded it, extract the files from the zip into your Mudrunner main directory. You're then going to open the zip file for whatever map you've chosen to use and move the 2 files from the levels directory into the media folder. Delete the levels folder from the zip. Then create a new folder named whatever your map is named. Inside the folder create a folder named Media. Then extract the remaining directories from your maps zip folder into that folder. After that move the folder with your map name into the MODS folder in Mudrunner's directory. Finally, enable the map in JSGME after you boot the game.

@toshd I tried that, the map won't even show up in the game for me. If i put mods in media.zip my mp gets disabled like everyone else. Hopefully someone can find a way around this.

@styphoryte You just need to copy those 2 files from the levels folder from your downloaded map, in the media.zip file, levels folder. That's it. Works multiplayer also.

If the map has more folders, it won't work the same way. I guess those maps that have textures and models of their own will only work with workshop.

A manual for the map editor to help you...

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.