Won't let me put a crane to the C-255. (tried on "The Island")

It happens only (for what I've checked) with the C-255. When you try to equip the Log Cart w/ Crane it always says "There's something blocking the area" and you can't use it in that truck, no matter what I do, the position of the truck, which garage is in...

(Alredy tried closing the game and switching garages. Tried with other trucks and it equipped the crane and all just fine. It's not the spare wheel's fault since it says "there's something blocking the area" as in clipping the platform with the crane, which is not the case).

Someone else tried? Is it just bugged for me? Help 😹

last edited by Filia

Doesn't do that for me. Loaded Island (just to be sure), and 255. Crane pops right on, no problem at all. That said, you also didn't tell us if you're console or PC.

last edited by kourtjestr

I dunno what's the problem, I come from the original Spintires, so I can't be missing some detail can I? I always could put it a crane in Spintires. Tried multiple times and won't let me with the c-255

Try deleting media.zip and verifying integrity? See if you just have a corrupt file?

Hmm sure. It doesn't mess with saved games, does it?

is crane support installed on front of truck?

The C-255 doesn't need one .-.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.