Unable to join multiplayer with friends

Hello, whenever I try to connect to my friends I get stuck in "Connecting to game" then "Timeout in X seconds" then "Game server connection failed".

Two of my friends are able to connect to each other, but when I host, I only enter the game alone and they both get the connection failed error.

I tried verifying the game integrity, I tried reinstalling the game completely, I disabled windows firewall, I never had any connection problems with other steam or non steam games.

Any ideas ?

Hmm no other firewalls working in background? Check if windows defender is not re-enabling itself. I remember when I wanted to disable windows defender it somehow reenables itself. Or just try and make exception for mudruner folder.
Another guess maybe try and reconfigure internet connection in windows. Also maybe your modem internal firewall is not configured properly for connection that Mudrunner requires.
I did not play MP yet so I have no idea if it works for me 🙂 I will check today.

Update. I cannot play MP 🙂 Says wrong map version and then message is shown that I need to copy some file.

last edited by CoSm1c gAm3r

There's a reply in the other treads :

HI all!
We're currently working on an update that will address the most urgent issues, including ones with joining multiplayer matches. As soon as we know more, we'll let you know.

last edited by WithStylez

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.