Can no longer use Logitech G27 after recent update.

Before the update, I could use my G27 fine other than the issue of the mouse jumping around if I touched my wheel/pedals in certain parts of the game. Mainly in the advanced menu or while trying to assign controls. That was pretty easily avoidable.

Now, after the update, the mouse is frozen in menus and in the map screen, it automatically moves the map view to the top. During gameplay, it automatically moves the camera view up.

I have tried deleting everything in the AppData folder thinking the update changed how inputs work but that did not help.

I have tried with "Use as primary device" on/off and with it off the wheel does nothing, with it on, the mouse takes over and only the keyboard can be used to control the game.

If anyone has a workaround or knows of a solution please share your knowledge. In the meantime, I guess I will just play using the keyboard.

FOLLOW UP
With the wheel unplugged I still have this issue. Tried deleting everything and starting over. It had no effect. The main menu is showing "press A" at the bottom even though I have no input devices connected.

last edited by PicSoul
Community Manager

Hi @PicSoul,

Thank you for the bug report, we're going to look into this. Much appreciated.

FIXED!

I believe it was a conflict with input devices.

Uninstalled EVERYTHING related to the game and still had this issue after reinstalling. Restarted my PC and it is now fine. I should follow my own advice as I always tell anyone having PC issues to try restarting the PC first.

You live and learn I guess! LOL

Community Manager

Oh, great! Thanks for letting us know how you fixed it. Enjoy the game!

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.