First Custom MR Map?

Heyo I ''finished'' my map but got no testers, so here you all go, decided to make a new thread for people to post complaints or suggestions for the map!
https://www.dropbox.com/s/p74z7m7a9i6x2t3/smugglers valley.rar?dl=0

And yes I know of the Typo, it will be fixed if I ever update the map.
https://youtu.be/GFG8-07g-S4

last edited by Kent_BoBo

@kent_bobo, Thanks for the map Kent. I'll be trying this asap.

EDIT: Cool map. I just tried it and had no problems on it.

last edited by Tattoo

Does this go right into the zip. That's how I've been installing mine

This post is deleted!

@roughrider, I load maps thru the config.xml. This way there is no extracting stuff or making a media folder or adding to the media.zip. I made a folder for maps, I use aMaps, and place the maps in there. But I DO change the actual download to take all the folders out of the media folder so they're all by themselves. So this map just has the levels folder in the .zip. Then I use this code and place it at the bottom like my gearshift. I find this a lot easier to manage things so everything has it's own spot and not all mixed up in the media folder.

<MediaPath Path="aMaps/Smuggelers Valley.zip" DoPrepend="true" />

I do mods like this too.

last edited by Tattoo

@tattoo said in First Custom MR Map?:

@roughrider, I load maps thru the config.xml. This way there is no extracting stuff or making a media folder or adding to the media.zip. I made a folder for maps, I use aMaps, and place the maps in there. But I DO change the actual download to take all the folders out of the media folder so they're all by themselves. So this map just has the levels folder in the .zip. Then I use this code and place it at the bottom like my gearshift. I find this a lot easier to manage things so everything has it's own spot and not all mixed up in the media folder.

<MediaPath Path="aMaps/Smuggelers Valley.zip" DoPrepend="true" />

I do mods like this too.

Interesting never heard of that method before , tutorial vid?

@smaronenine>

Interesting never heard of that method before , tutorial vid?

No, freeman showed me this long time ago and been doing it ever since.

I would love a tutorial on this method as well @Tattoo

good map so far on the first half of it keep up the good work

@tattoo Does that mean your multiplayer works?
I assume not.

@roughrider said in First Custom MR Map?:

@tattoo Does that mean your multiplayer works?
I assume not.

Yes and I can load the map in MP as well.

@tattoo Did not work for me. I get the files differ from package error

Here is a little update, was testing it out with a friend today and the main river was a little to hard for the 'ol C260, also I fixed the name.
https://www.dropbox.com/s/sqg8wekc9rtlq5n/smugglers valley.rar?dl=0

@roughrider said in First Custom MR Map?:

@tattoo Did not work for me. I get the files differ from package error

Yes, I just tried it with Blackwater Canyon and because of the costum objects, it didn't work in MP. Sorry, didn't know as I never did it for MP. I just did it SP. Sux it doesn't work cuz I like doing it like that. Sorry.

@kent_bobo, Sweet. I'll check it out soon. Thank you.

last edited by Tattoo

i use spintiremod 1.5.4 with mudrunner and i made a media folder in mudrunner directory and add media to config.xml so i can play blackwater and other map that have custom object in multiplayer

last edited by dan4762

All i did was open the config , enter <MediaPath Path="Media" />
then created a media folder , and i install them the same way as i did on spintires , drag and drop in the new media folder.
works fine....but i havent figured out the multiplayer yet.

last edited by SmarOneNine

@smaronenine said in First Custom MR Map?:

All i did was open the config , enter <MediaPath Path="Media" />
then created a media folder , and i install them the same way as i did on spintires , drag and drop in the new media folder.
works fine....but i havent figured out the multiplayer yet.

Spun and them got em working. Ask him. He should be able to tell you how to do it.

I just moved the files directly into media.zip levels. was playing multiplayer on it yesterday.
I'm also pretty sure Smar's way works too.

@kent_bobo said in First Custom MR Map?:

I just moved the files directly into media.zip levels. was playing multiplayer on it yesterday.
I'm also pretty sure Smar's way works too.

Yes, this map works fine but when it has custom objects is when they don't work.

@tattoo
Ah. I'm guessing Smars way would work, I have not gotten my hands on any custom models yet, and I want to leave the old stuff away from the new.

@kent_bobo, You would think. It should've worked the way I said too but doesn't because of map objects. So something's wrong and was surprised that map support hasn't been added yet. Maybe some day, huh? lol

@tattoo try spintiresmod 1.5.4 with mudrunner and i can play with custom object online and that can make the editor go in 64bits

@dan4762, thanks, I'll check it out altho I don't do MP with modded maps, atm. I was just trying to figure out for the others that want to know. Unfortunately, I failed. Sorry.

EDIT: Where did you get v1.5.4? I looked at the new site and stmods.ru and only v1.5.3.

EDIT2: Never mind. I found it down the list on stmods.ru.

last edited by Tattoo

64-bit vs. LBA
I'm not into code, but could somebody give me/us a rudimentary explanation of which of these would be more applicable to Mudrunner's obvious memory addressing issues and why?
If it's a stupidly complicated explanation, I'll try to wrap my head around it, and if neither 64-bit nor LBA is even relevant I'm okay with acknowledging my ignorance as well... lol
@Tattoo
@SmarOneNine
@dan4762
@Kent_BoBo

last edited by Mexican_420

@mexican_420, Sorry man, I have no idea.

@dan4762 said in First Custom MR Map?:

@tattoo try spintiresmod 1.5.4 with mudrunner and i can play with custom object online and that can make the editor go in 64bits

I'd be careful with this. Now that I tried it, when I open Max 2014 it asks me to activate it now when it didn't before. It may be coincidence but it never did that before so I dunno if I'd trust it. AND, I got a violation error when trying to run spintiresmod. So basically it's junk to me. Frickin' russian garbage!!!

last edited by Tattoo

@Tattoo
No worries, mate. After a quick Google search, I figured out that LBA is relevant to HDD access and has nothing to do with RAM...
Apparently 32-bit apps aren't capable of "seeing" RAM in excess of 3GB, so my presumption is that Mudrunner (being a 32-bit app) reserves 1GB for it's "back-end" stuff leaving only the remaining 2GB for loading assets like trucks and maps. Nor sure if consoles run in a 32-bit environment, but if that's the case then we may never (?) see a 64-bit incarnation of Mudrunner (gotta love that "lowest common denominator" approach) which will add a whole new wrench to the works when it comes to mods...
Anybody who might be able to shed some light on this would be a hero...
@Pavel
Any input here? I know you're a busy guy... 🙂

@tattoo i used the 4gb patch too and it work

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.