Mouse Click Issues

I've had a problem with mouse clicks not registering while in game and moving mouse. It's not 100% faulty but can still be annoying. I'm linking a video to show the problem. I've tried multiple things to fix it. I've changed mice, I've uninstalled and reinstalled the game, and even looking online I can't find someone with the same problem except for players on the Overwatch forums. They're using laptops though. I'm using a desktop with no touchpad. Any help would be appreciated. Should also note that I've had this problem in one other game; Paladins.

Video

Doesn't look like a hardware problem since the click is registering but it appears to be intercepted by software. I'd suggest to try any of the following steps:

  • even though it doesn't appear to be a hardware issue, switch USB ports first (try to use it on a 2.0 port, see your motherboard documentation) and see if the issue disappears
  • check your applications running in background. Is there anything that might intercept input?
  • uninstall any additional mouse software that's not necessary for the mouse (meaning all except drivers)
  • uninstall all mouse drivers and try without it
  • take a look at the settings in the "ease of access" windows system controls. I'm not sure if you'll find something there, but your problem appears to be somewhat similar to the keyboard help windows is implementing, like pressing shift 5 times to enable sticky keys etc

Thanks for the suggestions. The bad news is that none of that worked. The good news however, is that I was able to fix it. I was in borderless windowed and apparently that was issue. After I switched to fullscreen, it corrected itself.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.