Performance

Anyone seeing improved performance over Beta 1? I sure am not.
In an initial online game in Crossing map, even tho' my FPS is locked at 55, I was rarely seeing it hit that...more like the low 30's and 40's. I did better than that on Beta 1. And I'm running all Medium settings, 2GB 1050 TI, hex-core 3.5Ghz AMD+ 6300, 16GB RAM.
Also, it is STILL a pig memory-wise. Idle (not in game) it's taking 3GB of RAM. When in game in Solo mode it's drinking 5 to 5.5GB. This is gonna suck for most laptop players.

R9 290, i5 4460, 8GB RAM

Performance has improved for me if I check Steam's FPS display, I get around 80 FPS now instead of the 30-50 in Beta 1 and Alpha with everything on low expect Post Processing, Texture Details and Antialiasing, these are on high (doesn't matter if I lower the high settings, only my GPU usage drops but I still get the same FPS).

However I have terrible stutters, dropping below 60 FPS (when turning fast, when shootnig enemies, when some action goes on) somewhat frequently and sometimes it drops to a single digit FPS (no idea what causes this, haven't found a pattern yet). Overall the game doesn't feel any smooth.

Edited with some details

last edited by McFosat

Same for me, I have performance drops on shoot and quick mouse movements.
Specs :

  • Ryzen 7 1700X OC
  • R9 980
  • 8GB 3000Mhz RAM

All options are on the lowest possible, I even lowered the definition, still at 55fps max with drops

Is there any known software solution?

Hope this will get fixed soon 🙂

I saw a pretty good jump in this beta so far. I get around 100fps when running to a cap point and about 80+ when in combat maybe some 60's if its really busy. 1700x 3.9ghz, GTX 1080, 16GB ram. aa-med, texture and effect high and everything else low. I'm sure not everything is optimized yet.

@sugabomb said in Performance:

1700x 3.9ghz, GTX 1080, 16GB ram. aa-med, texture and effect high and everything else low. I'm sure not everything is optimized yet.

Given that many of us are INS longtime players, our hardware is not all that powerful. This is really gonna suck for a large percentile of the base if they can't produce better optimization. I don't mind drop'n settings a bit, but we need at least 60fps across the board. Frankly, I'm not seeing that yet.

Seeing improvement since beta1, 90-100 fps with GTX 970 and i5 2500k on firefight. On skirmish it's 60-70 fps. No stutters.
Most settings on low.

last edited by zefs

@zefs said in Performance:

Most settings on low.

Well yah, but given how well UE3 games run on my system they should be able to do better than this...I'm wondering if UE4 was the best choice. Running a game at low with your given specs is a bit ridiculous.

last edited by Mamba

performance is very bad for me, some games are playable although I still get stutters, others are a freeze fest! and that's with everything set to medium, I can play squad with everything maxed and get a better gaming experience and that uses the same engine as this.

this game is still poorly optimized, even when im getting 90/100fps (which I do sometimes) I get random stutters for no reason? its a shame as I would love the game if it played as smooth as the first one
my specs are

i36320
gtx 970
8gb ddr4

last edited by syks01

Are you guys using SSD's?

@dafez said in Performance:

Are you guys using SSD's?

Nope, I have it on a standard drive, but it shouldn't matter, other games play fine

Get an SSD. Single best upgrade you can do! Your HDD is likely the data bottleneck now.

Just to add a little more to what I was saying....for those with a lower end gfx card with lesser vram, your hd is going to be accessed for textures etc more often....hence why I'm saying your hd is a bottleneck

yes I see what your saying, but it dosnt answer why every other game runs fine that ive played including games that use the same engine? I only have problems with this game 😞

So I'm getting unplayable levels of frame rate drops. The performance seems to be exactly the same on the highest graphics as on the lowest graphics. I also just experienced a hard freeze that caused me to have to hard shut down my computer, and it was caused by what I can only assume was sprinting in a straight line for to long. So ya wtf is going on.

@dafez said in Performance:

Are you guys using SSD's?

Yes I put Beta 2 on my SSD and still having the aforementioned issues.

okay better than beta 1 however while ads droping frame or stutter alot and also found that stutter alot when ads with a 2x sight or more, 1x sight run better

last edited by Danrobi

@dafez Yeah i've got mine on an SSD and it still has performance issues.

Specs: i5-8400, 16GB RAM, GTX 1060 6GB and the game is on the Samsung 850 Evo.

I would like to add that every time when I bring up the commo rose the framerate tanks for a few seconds.

Yes, both my drives (system and data/game) are SSD.

I'm going to "me too" with the performance thing. Bear in mind I'm running it in 4K, but I have a pair of OC'd Titan X Pascals. Unfortunately there still isn't a usable SLI profile yet, so that's definitely hurting.

The main issue are the frame dumps. If it was a steady 55FPS, that would be one thing. It would suck pretty badly, but it'd be one thing. What I'm experiencing is rapid and random frame dumps: it'll be sailing along at 85-90FPS and then tank to 40 or less. Then back up again. Generally it happens when the fun begins. IOW: fire fights.

This is akin to what guruguru was saying above.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.