Brightness increase bug

I've noticed that overall brightness seems to increase a bit after a short while in a match. When i press escape twice to get into the menu and back into the game the brightness is turned down again noticably. Here are two scenes in comparison before and after:

Before
0_1535661253556_20180830221445_1.jpg
After going to menu
1_1535661253556_20180830221449_1.jpg
Before
2_1535661253556_20180830222412_1.jpg
After going to menu
3_1535661253556_20180830222416_1.jpg

Just for clarification, the reason why i caught on to this is because in certain scenes the increased brightness results in a noticably washed out image, or "too bright".

Here's another scene depicting this behaviour quite nicely. Maybe an HDR bug?

Before
0_1535663733792_20180830230458_1.jpg
After going to menu
1_1535663733792_20180830230500_1.jpg

I can reproduce the first image just by going to the balcony on the right and looking at the street for a bit, and then returning there.

last edited by Feuerholz

thought some areas got really bright for no reason, and made a thread of it, thanks for looking into this.

thanks for the post, same here. noticed when i was squinting and my eyes hurt after a couple of rounds

The bug is still there with an RX580. Does anybody else experience this?

Yes, I've also reported it on the pinned topic. I think the game picks the menus' post process parameters and applies them on the game when you exit it.

last edited by zefs

Still happening, and kinda annoying. I regularly switch to the menu and back to reduce the brightness.
Post processing settings from low to very high have no influence. The other settings don't appear to impact it either.

1_1536508409386_brightness01.jpg 0_1536508409386_brightness02.jpg

yeah i get this alot but weirdly its the other way around.
my screen will go really dark then graduate back to bright again almost like the game is switching to dusk or very near night

specs for comparison

i7 7700k
evga 1080ti hydro copper
16gb ram
ssd
windows 10 pro

I've experienced the same resetting with other settings within the game as well for some reason it resets a lot of stuff back or moves settings without user input.

last edited by kush_kill

try changing the GAMMA in the engine.ini file

i have found that putting gamma to 2 (which is default) or 3 if you want it brighter, does not allow the gamma to change during gameplay!

i also set my supersampling and postprocess AA in the engine.ini file which produces way way better results than the in game settings and it sticks!

i am not at home now but ill add to this post at peoples request when i get in!

the game is stable and sharp as fcuk without flickering now for me and im always over 100fps on 1440p with 6700k and gtx 1080

@dirteebreaks said in Brightness increase bug:

i am not at home now but ill add to this post at peoples request when i get in!

Bump, could u?

sure!

goto this address in explorer

C:\Users\YOURUSERNAME\AppData\Local\Insurgency\Saved\Config\WindowsClient

open engine.ini with a text editor

delete all existing and place this

[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Insurgency/Plugins/Wwise/Content
Paths=../../../Engine/Plugins/Editor/CryptoKeys/Content
Paths=../../../Engine/Plugins/Enterprise/DatasmithContent/Content
Paths=../../../Engine/Plugins/Media/MediaCompositing/Content

[/script/engine.renderersettings]
r.MSAA.CompositingSampleCount=2
r.PostProcessAAQuality=4
r.ScreenPercentage=100

[/script/engine.engine]
DisplayGamma=2

save the file and right click it and click properties and tick the box that says READ ONLY and hit OK

the MSAA can be set to 2,4 or 8 but 2 is best without raping the GPU
Post AA you can mess around with but these settings are great for me.

Gamma default is 2 and 3 is quite bright

@dirteebreaks thx for your reply, i thought i will see something new, but i already have this comms in my .ini.
Btw "r.MSAA.CompositingSampleCount=2 and r.PostProcessAAQuality=4" kinda breaks holo crosshairs(kobra, aimpoint, holo) it become even more fuzzy and have some pinky color for me.

Odd, my sights are fine.
I do use a 1440p monitor though.

Maybe you can play around with the values?

Either way it produces way sharper AA results than the ingame settings without raping gpu usage like SuperSampling does

last edited by Dirteebreaks

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.