96-98% ram usage.

I have 32 gigs of ram. Plus the 8 in the video card. I have been seeing stuttering and my ram usage is maxed. This is all new since alpha. There were no scans. No other programs. No recording. Just me and the game. On a plus side, my 1080 is seeing max usage too!!!

Edit - when this happens a system restart fixes it, though there is prob a program I could end to fix it after closing the game. just dont know which one.

last edited by Max80

wth my 8gb system memory only gets used to about 80% on low graphical settings however

@max80 said in 96-98% ram usage.:

I have 32 gigs of ram. Plus the 8 in the video card. I have been seeing stuttering and my ram usage is maxed. This is all new since alpha. There were no scans. No other programs. No recording. Just me and the game. On a plus side, my 1080 is seeing max usage too!!!

Baffles me that this is happening with your setup (dual 1080s, 32gb ram)

Just as a comparison, my rig
i7-6700k
MSI GTX 980Ti (only one, not two!)
16 GB RAM DDR3(!!)

Playing @1080p

Performance: 60 - 120+ FPS (BUT can drop down to 2 - 60 FPS)
GPU Usage: 15 - 99% (it's mostly at 99% in spectator mode or in the menu) while playing it's mostly around 40 - 75%
CPU Usage: 30 - 60%
RAM Usage: 6-8GB

Conclusion:
Optimization is not working as it should and needs to be done in the future. It only can be this. There's no other explainable reason why DUAL 1080s and 32GB of RAM!!! Max out your GPUs VRAM and RAM ...

Update: I know that using GPUs in Dual/SLI can cause problems if the game isn't optimized or meant for being played in SLI.
Can you maybe test it with only a single 1080 running? And check your VRAM/RAM usage again and post here?

last edited by SirPenetrator

@sirpenetrator My thoughts too. Thank you for understanding

@max80 said in 96-98% ram usage.:

@sirpenetrator My thoughts too. Thank you for understanding

Can you test with a single, only one GPU?
Only if it is not too much work for you. If you can't it's okay too 🙂

@sirpenetrator Oh I already have. It still happens sporadically. Though a few minutes ago I think I found what triggers it. Alt-tabbing in and out from the game to something else, causes a lot of hiccups and freezing for a few seconds. It seems to struggle to do this with Insurgency Sandstorm. When this happens it sometimes has high ram usage and doesn't always recover properly.

last edited by Max80

@max80 said in 96-98% ram usage.:

@sirpenetrator Oh I already have. It still happens sporadically. Though a few minutes ago I think I found what triggers it. Alt-tabbing in and out from the game to something else, causes a lot of hiccups and freezing for a few seconds. It seems to struggle to do this with Insurgency Sandstorm. When this happens it sometimes has high ram usage and doesn't always recover properly.

Well, that's obvious because it has to run your game in the background and bring you back to the desktop and providing enough RAM there.
Best way to test ram/CPU/GPU Usage WHILE playing game is with
MSI Afterburner - you can activate an On-Screen-Display so you see RAM/CPU/GPU Usage while ONLY playing the game and not alt-tabbing outside of the game.

@sirpenetrator My reasons using that thought was that I have never seen it struggle like that with any other game.

@max80 said in 96-98% ram usage.:

@sirpenetrator My reasons using that thought was that I have never seen it struggle like that with any other game.

That's because Insurgency Sandstorm is still in Beta and not optimized enough.
I bet you if you use MSI Afterburner and monitor the usage of RAM/CPU/GPU while playing the game normally, you will see a difference.

last edited by SirPenetrator

I have MSI after burner. I cap my fps at 70 with Riva Tuner which comes with it. I monitor my system specs with it. As per my previous post the ram usage isn't like that all the time. Something screws up when I alt-tab. Something that doesn't recover and it sits at max usage. (I just need to stop doing that.) And yes I know its not done yet, the game. I was just reporting it here.

last edited by Max80

@max80 said in 96-98% ram usage.:

I have MSI after burner. I cap my fps at 70 with Riva Tuner which comes with it. I monitor my system specs with it. As per my previous post the ram usage isn't like that all the time. Something screws up when I alt-tab something that doesn't recover and it sits at max usage. (I just need to stop doing that.) And yes I know its not done yet, the game. I was just reporting it here.

Ah okay, then I didn't understand you right, sorry 🙂

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.