game unplayable after todays patch (02/09/2018)

Well things were looking up, but after todays patch the game is basically unplayable for me! talk about a step backwards! every game/map (dosnt seem to matter) has more stutter than EVER! frame drops are MASSIVE now for me as well going from 60fps to as low as 6fps!

This patch is terrible for me and now the game plays worse than ever, even the alpha was more playable than it is now,plus im sure the graphics look quite a bit worse after this patch,things are supposed to get better not worse lol and im worried more than ever now as there is not much time before release 😞

my specs are

i3 6320
gtx 970
8gb ddr4 ram

it's great better for me. but not awsome. drops in scope and area.

@julien said in game unplayable after todays patch (02/09/2018):

it's great better for me. but not awsome. drops in scope and area.

whats your specs please?

i7 7700k
32gb
1070ti

i play in 4k

last edited by julien

@julien said in game unplayable after todays patch (02/09/2018):

i7 7700k
32gb
1070ti

i play in 4k

lol with that sort of rig it shouldn't of been too bad anyway lol I only have a modest setup but havnt had ANY problems playing any other game really, 90% of games I can play maxed out and get above 60fps including games that use the same engine as this, im playing this on medium settings and now after todays patch its unplayable 😞

Just hope by the time of release it is all sorted and running A LOT better

nwi have many work on optimisation and performance but i believe in it... just let the time for.

The game is better for me now!
I think with the "frame rate smoother" disable, the game runs better! Try to change your game settings!
I have a Core i5 6600k and a Rx480 and 16Gb ram here!
Im running the game with texture and foliage on high and the rest on medium.
I found that Post processing on high drops 20fps or more in the game, also effect drops fps a lot! I can get 60 - 90fps with that settings! High scope detais make zoom more cool but drops fps too.

last edited by Shadoware

@shadoware said in game unplayable after todays patch (02/09/2018):

The game is better for me now!
I think with the "frame rate smoother" disable, the game runs better! Try to change your game settings!

do you mean disable the "smoothing"? as I have that on and game locked to 60fps

You will have to try different option to find what is best for you!

nope, just tried again, with smoothing and without, game unlocked frame rate and locked at 60fps, its absolutely TERRIBLE for me, constant freeze/stutter fest no matter what I do, this patch has screwed it for me 😞

Try the way you were playing before and just set texture to a level lower. You problem sounds like the game wants more memory. If that is really the case, using low texture may help.
If you use Riva Tunner you can check what the game is using more from your system. Search for a tutorial on youtube.

last edited by Shadoware

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.