Performance Feedback Thread after Beta 2, Hotfix 2

I figure I'll post this here in case the devs miss it on the steam forums.

  1. Windows 7 Pro- 64bit

  2. Intel i7 - 4710MQ 3 GHz

  3. GTX 970M

  4. 16 GB RAM

  5. Mechanical HTSG 7200 RPM, 1TB HDD (Running on my Primary Drive: Samsung EVO 850 150GB SSD has no noticable difference)

  6. Hotfix 2 did improve performance marginally but the stuttering is still very noticeable when server capacity is high or maxed. There is occasional stuttering in low capactiy servers but not as bad as a highly populated server and it is worst on the map Summit, which remains unplayable where my FPS will range between 10-90.

The microstuttering is prevalent when my game drops 60FPS and screen pauses for a very brief moment (half a second) and desyncs at 10FPS. The drops in FPS are usually caused by aiming in different directions/doing a 90-180 degree spin, rendering a new room/area/road, when excessive particle effects from both explosions and gunfire are visible on screen, or when multiple player models (enemies) are on screen at the same time.

When idle, the FPS is stable and the game runs smoothly until another/mutliple player model(s) or asset enters the field of view, which will cause a drop in FPS again from about 85 to 30FPS. Additionally, massive FPS drops occur (90-7 FPS) when spectating from player to player, when re/spawning or using an optic with any form of magnification (1x are unaffected). Spectating players also has microstuttering when the player does anything mentioned in paragraph 2 above.

  1. https://pastebin.com/4ewawqKX

  2. All settings are on low or off (if applicable) with resolution at 100, vsync off (if on, no difference in performance, only absence of screen tearing- which I don't mind). The aspect ratio is lowered to 720p (native is 1080p) which very slightly improves performance. Enabling FPS Limiter to 60 or lower has no effect on the stuttering issues mentioned above or performance.

  3. Fullscreen, always. If borderless or windowed, FPS will drop dramatically and be consistent between 15-30FPS (which usually occurs in all other games due to the refresh rate of my desktop).

I applaud you guys for releasing this hotfix because it did noticably improve my performance and the microstuttering isn't as frequent as it was before but I'm still having the same issues, just not as frequently. Summit is still unplayable.

Good post sir!

I run a similar build as yours (i7 4710HQ, GTX 980m, 16 GB RAM, installed on HDD), like you Summit has a lot more performance issues than the other maps I’ve played so far.

I mentioned before how sceneries with pronounced depth of field were instances where I noticed the framerate drops. On Summit, I can’t pinpoint what’s wrong, just feels generally sluggish all around.

After first hot fix, I could run the other maps on Very High fairly confidently, with occasional drops but nothing unplayable. Summit has forced me to crank it down.

@psychofleyx Nice, Farmhouse for one runs smooth as butter for me. All others have a slight performance issues with Summit being the worst.

I've also noticed when using certain magnifications the textures re-render in the scope and peripherals.

last edited by imacookie

I agree with this post entierly , Summit is the worst map for optimisation , shame , it looks like one of the best map design wise tho'.

big bump.
Im having that 90-180 degree spin issue as well (in addition to all the other issues youve stated) i thought it was an issue with my mouse at first.
and lowering the settings does little to nothing at all when it comes to trying to fix the stutter and freezing.
the most annoying thing ever is when the game freezes for about half a second every time another player model enters the field of view, its gotten me killed a fair amount of times.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.