TURN YOUR HYPERTHREADING OFF!!!!!!!!!

I have been searching for i fix to me shuddering and drop in frames while ADS . I am running a i7 6700 with a gtx 1080 ti and had hyper threading enable i bois. Upon some research i seen someone had posted to turn off hyper threading and he was laughed at in the post. I thought i would try it.
enabled- 80 to 110 frames with shuddering while ADS.
disabled- 130 to 170 frames and run smooth as butter now. I will try running everything on high now as my monitor has a 165 refresh rate.
this is a possible explanation.....

Depends on the game. Many people blindingly say no to this sort of thing. There is a reason why AMD chose for the longest time to abandon multi-threads, in favor for the higher TDP method of just providing more cores. E.g. FX series processors only had as many threads as they did cores. While intel i7's were rockin only 4 cores and an additional 4 threads. Of course, this didn't prevent AMD architecture at the time from running like dog, and essentially just generating a lot of heat, sucking a lot of power and not producing efficient results lol.

In most games single core performance is the best.

Hyperthreads are "logical cores," and are thus seen by the OS and software as virtual cores. Many games only support a certain amount of cores anyway...best to give the game actual dedicated cores. Essentially, many games will use the threads and treat them as cores. This also increases chances of something called thread collisions, which is when an app may try to use the same thread for multiple purposes, or even multiple processes and apps trying to use the same thread...since things happen in the background of your OS as well.

This is something you will have to monitor and choose accordingly for the game. That's why there are apps like "CPUcores" which let you toggle the HT functionality, among other things, preventing the need to have to pop into Bios and permanently disabling/ enabling.

You may also want to run a couple bench tests to see how it fares for you and what your game is using in the first place. DX12 titles, though, can be tricky...since it relies a lot on computing power e.g. the CPU is playing a more major role. Only tests can tell you. However, if someone only had two cores, I'd say role with the threads. But if you have 4+ cores, you may stand to benefit from not only disabling HT, but you might stand to gain from disabling actual cores in some games, too. It's known that some games do better with fewer cores at higher clock speeds, than many cores...especially if said game wasn't designed to use many in the first place. Again, you can take pretty much any game and see how many threads it will use, then whether they stand to gain from disabling threads/ CPUs in the first place. Up till about 2012/ 2013 most games really used two CPU cores. It really wasn't till around that time they started leveraging quad cores and up...

( Windows 7 Professional 64 bit )

EDIT ( deleted old text : 08.09.2018 18:05 O´clock )
( Deactivating any of the "4 Hyperthreading Cores" in Windows 7 : start msconfig.exe --> Tab Start --> expanded Options ---- >CPU count didn´t work for me )

But .... After disabling Hyperthreading in the BIOS the game rocks with stable 100 - 120 FPS , smooth like the old insurgency !!!
Yes baby ! That´s what i am talking about !

Intel Core i7 ( 4 Cores active )
In BIOS ---> CPU Options ----> Disable Intel HT technology --> save and exit --> reboot and voila ! Now the game is really fun to play ( without stutter ! )

@BurgRat
THANK YOU !

last edited by GSG_9_LIGHTNING

My game was running horribly. I got around 25-35 fps whenever I saw another player, and oftentimes the fps even dropped down to 1. It was like watching a slideshow.
But then I disabled hyperthreading..

BOOM!

Buttery smooth 80 FPS.

I have an intel i5 4670k, 8GB ddr3 1600 ram, and a 4GB GTX 960

last edited by MusicNote

@musicnote said in TURN YOUR HYPERTHREADING OFF!!!!!!!!!:

My game was running horribly. I got around 25-35 fps whenever I saw another player, and oftentimes the fps even dropped down to 1. It was like watching a slideshow.
But then I disabled hyperthreading..

BOOM!

Buttery smooth 80 FPS.

I have an intel i5 4670k, 8GB ddr3 1600 ram, and a 4GB GTX 960

Hmm Interesting to know i5 got hyperthreading

AMD doesn't have hyperthreading because it's Intel's trademark.

last edited by Kraeyq

@trollmilitia said in TURN YOUR HYPERTHREADING OFF!!!!!!!!!:

Hmm Interesting to know i5 got hyperthreading

But that i5 doesn't have HT

@mcfosat said in TURN YOUR HYPERTHREADING OFF!!!!!!!!!:

@trollmilitia said in TURN YOUR HYPERTHREADING OFF!!!!!!!!!:

Hmm Interesting to know i5 got hyperthreading

But that i5 doesn't have HT

😉 😜 😉

Turning off HT on a Intel 5820k / X99 in BIOS had no positive effect.

Following the suggestions in this thread, I tried to find a way to set the game to run on my hard cores rather than the hyperthreads through software alone. (As disabling hyperthreading universally isn't an option for some of the 3D software I work with daily).

Unreal Engine 4 has a launch command for setting the logical processors the games threads will run on. -PREFERREDPROCESSOR 4 in the games Steam launch options will tell the game to run on the processors first 4 cores, which in the case of my i7, should disable use of the last 4 hyperthreads. So far I've noticed with this tweak that input lag seems substantially reduced and the frequency of microstutters and texture pop-in is noticeably less, though I wasn't able to verify if the game is indeed only sticking to the first 4 cores, as software monitoring options for this seem limited at best.

I recommend anyone else who's seen benefits from disabling hyperthreading at the bios level - try re-enabling it, and using the launch command to see if the benefits are the same.

last edited by 11.11.11

just google how to enable all cores, for your computer and you can pick how many cores you run the game on. I disabled hyperthreading in the bios and have 4 cores running at boot up as i have a i7 quad core. I could use 8 cores as an option but runs better on 4 cores.

is there no way to disable the use of HT in game? as i dont really want to disable it system wide as soo many other games need it

@dirteebreaks said in TURN YOUR HYPERTHREADING OFF!!!!!!!!!:

is there no way to disable the use of HT in game? as i dont really want to disable it system wide as soo many other games need it

I think it is not really a difficult task to restart the computer, press DEL button during boot sequence and then open the right tab for the CPU settings in the BIOS and disable/enable the Hyperthreading option. Rebooting does take the longer time with aprox. 40 seconds.

This whole thing is done so quick that it really does not bother me when i need all cores activated for some other Application/Software/Game.

last edited by GSG_9_LIGHTNING

I understand ur point but its still a pain the ass lol
Ill give it a shot though

Makes no difference to performance, This games performance is limited by GPU optimisation more than CPU. Turning of hyper threading is just putting you at a greater chance of pegging out your CPU usage to 100% which causes more stuttering. And this does not increase your GPU usage at all when doing this..... U4Engine is GPU hungry, Not CPU hungry so this trick should not be advised!

last edited by FaTTMeDic

@fattmedic Hyperthreads are "logical cores," and are thus seen by the OS and software as virtual cores. Many games only support a certain amount of cores anyway...best to give the game actual dedicated cores. Essentially, many games will use the threads and treat them as cores. This also increases chances of something called thread collisions, which is when an app may try to use the same thread for multiple purposes, or even multiple processes and apps trying to use the same thread...since things happen in the background of your OS as well.

@burgrat Still doesn't help the performance however you want to justify, I've tried this idea and yes its a "idea" But all i see is worse performance with lower max fps and no difference to the min fps. What i did see is my CPU usage spiking to 100% in areas which is why my max fps is capped out lower than it usually is with hyper threading enabled. Modern games are coded to utilise 4 cores with hyper threading as this is the majority of what users run nowadays, Unreal4 engine is one of those that do this in particular.

last edited by FaTTMeDic

@fattmedic totally right i thought as much before i tried it and like a sheep i tried it.

Made no difference at all, my cpu load minimum anyway (6700k @4.5ghz)
Maybe this may help people with cheap or very old cpu's?

The gpu usage amd crazy over the top Vram usage is and always has been the issue with indy developed unreal engine 4 games.

Its the same story every time and every game, the indy devs take on too much when using UE4, i really dont see the fascination on using UE4 as sooo many devs are using it in last 2 years and nearly ALL of them are having problems.

Devs need to do their homework and avoid UE4 in the future

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.