WESTERN STAR 6900XD +CHEVY BISON

hi Guys
I do not know. my training as a truck mechanic tells me it does not work that way if you put a diff housing on a non-driven front axle
  you do not have a driven front axle.!
0_1542052735145_Spintires  MudRunner Screenshot 2018.11.12 - 13.30.43.93.png
0_1542052799298_Spintires  MudRunner Screenshot 2018.11.12 - 13.26.29.78.png
my request to the devs. please fix that.
since you were very accurate with the russian trucks.
but that's an absolute no go, it almost looks like you've gotten a SketchUp 3D model and revised it a bit.
and sorry for my hard comment
and please also fix the lighting right away

if nobody noticed it
the front axle of the chevy bison hangs in the air there is no connection between axle and springs0_1542054334215_Spintires  MudRunner Screenshot 2018.11.12 - 13.21.11.20.png 0_1542054393818_Spintires  MudRunner Screenshot 2018.11.12 - 13.24.10.11.png
that looks absolutely crappy.
an absolute no go please can this be fixed
And that does not come from the other tires I drive which have the same diameter as the standard tires

last edited by thombuggy

@thombuggy
Good luck with that. They haven't fixed any of the much more obvious tire or log rope clipping issues, so I doubt they'll be fixing this one. But yes it would be nice. Try not to look at it too much.

Time allowed versus time needed to work on the dlc?,or they had some asset, decided it was enough, given for them it's more a waste of time to work on that version wich is in the end of life.
On the other hand i hope in the next version will be a base they build uppon and not iterate each year or two a new version, so people can look forward in the way of Euro truck simulator, ATS or Warframe.

last edited by Raphael

@thombuggy
Dang it, now that you pointed out the missing front suspension on the Bison it bothers me too. LOL. That one's actually pretty easy to see, much more than the missing front half shafts on the Western Star. The devs really should fix this. It's a major oversight on their part. @Iyagovos

Community Manager

I've passed it along and will keep asking them to fix it.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.