PS4 Blood Angel Campaign Mission XII Issue (Bug?)


I have been playing the game recently and really enjoying it, quirks aside.

However one issue that has been ruining it, has been the problem I have with the Mission XII. I have attempted the mission multiple times. So far, it has crashed the game back to the PS4 XMB in every attempt. This is post patch install on the PS4.

Sometimes it is within the first move or two that I play. Other times it is later, one excruciating attempt it was at about turn 10 : ( I have yet to be able to complete this mission. Additionally the character models are incorrectly displayed for each model every time I boot this mission up. This has occurred previously in my game but it has ever seemed to effect the game that much.

I contacted the Twitter account and they said to send in my save data. I have this on a USB stick now and am ready to send it in. If someone could give me an email address to send it to via the WeTransfer as suggested by the Twitter account I will do so.

Unless anyone here has another suggestion that might help?


Hello, can you send the save data to please?
We'll investigate this issue!
Good day!

I have now done this.

Thank you

Hello, do you use a PS4 or a PS4 Pro?

Thanks, we're investigating.

If you save your mission at the end of each turn, are you able to finally beat the mission or are you stuck in a state where the game crashes everytime?

I have yet to test that out. I will try tonight.

Ok. So save scum'ing worked. It had one freeze as I was playing and had to reset the game to continue. When I reloaded the game save the map had the character models as if starting the map anew AND the character models as I left them in the previous save??? That aside it worked normally.

I suppose that is the way I will have to continue to play the game for now?

Weird. I have played through the Blood Angel campaign twice. Once, the day the game was released, and again following the latest A.I.-patch. I have never had the game crash.

Are you experiencing random crashes often, or in other games? Could it be a hardware defect?
Are you playing on your television, or do you use a different monitor? I recently got a new TV, and my PS just would not boot, on it. Checking System, Error, Repeat.
I ended up resetting the console, and as always, that did the trick.

Youtube Video

Good luck!

last edited by Cloud Runner

@cloud-runner Thanks for the response.

I am inclined to believe it is not a hardware issue.

No random crashes in any other games. I play often enough (usually daily) that I would notice this if it occurred with other games. If that did occur, I too would suspect the Pro needed a reset.

I play on TV, same model TV I have had for this entire gen with no issues. Including my old PS4.

Although I am not sure the patch is the issue either because I did have similar issues with the game pre-patch. Character models loaded in the incorrect places etc. It was just not as noticeable as the issue with that particular mission.

Either way I have now completed the campaign. So I feel better for that. I enjoyed the experience on the whole.