Insurgency Sandstorm Server Assistant Released

@QuantumNuke75 Got the same error, any idea how to fix it?

"Index was outside the bounds of the array. occurred in QueryServer."

last edited by Olanov

@Olanov said in Insurgency Sandstorm Server Assistant Released:

@QuantumNuke75 Got the same error, any idea how to fix it?

"Index was outside the bounds of the array. occurred in QueryServer."

The app is currently broken with the latest server version. With limited time to spend on it and the fact that nobody has confirmed the exit problem I posted a couple of days ago, it is unlikely to get fixed anytime soon.

@Pointy I pressed Ctrl + C while in the Server (DOS?) Window and it closed
Don't know if this helps you

@Pointy My apologies. I saw some chatter but wasn't sure if it was regarding the same subject. Thanks for your clarification.

Small issue - can the applciation window be made resizable or maximizable when you next release it please? Only on my PC (and anyone with a scaled font I guess?) I cannot see all of the options eedda72c-64af-41cd-bd1d-8ea4b7b0e7c1-image.png
Thanks

How to add new map Ministry and Outskirts

Thank You.

@Pointy said in Insurgency Sandstorm Server Assistant Released:

@Commando-Cat

With your server running 1.2 (and nobody playing 😉 ) Make sure the server window is active and Press Ctrl+C together. Mine goes through the shutdown process, but hangs on exiting and the window doesn't close.

Okay yeap, I get this problem too if i use Ctrl+C. If I use the red STOP server button on your server assistant after i press Ctrl+C and the window doesn't close, the console window closes though.

Also, using the red STOP server button to stop the server (when it's running) will close the window properly.

Also just so you know, v1.3 is out too which added Ministry and Frenzy Checkpoint. LOL.

last edited by Commando Cat

Send me dat source ZIP so I can clean it up for release please 😃

Has any progress been made with this assistant

bump.
maybe a developer response?

bump the 2nd

I wonder why the devs themself don't provide a tool for setting up a dedicated server...
They should be able to do this quite simple and fast.

last edited by beerz

Can this get an update? It has been a while since a new release, and with 2 new maps, hardcore and frenzy mode, nothing seems to work. Also, current server connections are showing "Failed to connect to the remote server 'Drunken Republic Gaming' The server is either down or the query port is incorrect/not forwarded." This was a great utility, but now its a waste of space. I really enjoyed it and would like to see a fully updated version that works with the newest patch. Thanks for all your hard work, I love this tool!!!