Issue with game launching in wrong screen (for multiple monitors).

When game launches the pre-launch title card thing shows up on the propper screen but when it cuts to black and starts the advertisments its on the wrong screen and I can't seem to move it. Tried chaning the window type (Borderless Window, Window and Fullscreen) and move it over to the proper screen like every other program, but that doesn't work either. Tried hovering over the minimized window on the task bar, right-click on the window and tried to move or resize didnt work on any of the game window options. I would just play with that screen if it wasn't for the fact its like 14" and like 10 years older than my regular monitor.

I have this problem too.

Steam is on one monitor. When I lauch the game the initial splash screens are on that same monitor and then poof...game is on my second monitor and I cannot move it. Changing to windowed mode does nothing.

I checked and the monitor I want it to play on is designated as my primary monitor. Doesn't matter, still goes to my second monitor. I have to unplug my other monitor to force the game onto the monitor I want it on.

Can confirm this. I had my TV connected as a second screen, but it was switched off while gaming. Then everytime while starting a Multiplayermatch i got stuck in the loading screen on my mainscreen. Game must have been on second screen. Unplugged the second screen now and now it loads correctly. But now i got an isuee with direct win or loose a match, after loading^^

Hello,

You can try to launch the game in Steam's Big Picture Mode. That will allow you to choose on wich screen you want the game to launch (in the Resolution settings of Big Picture).

Hi,

I have this issue too, launching Big Picture Mode and changing the monitor does nothing.
Big Picture Mode comes up on the correct monitor and the game still does not.
The correct monitor is set as Primary, but in display settings shows up as Display 2.
The incorrect monitor is shown as Display 1.

@serdalis said in Issue with game launching in wrong screen (for multiple monitors).:

Hi,

I have this issue too, launching Big Picture Mode and changing the monitor does nothing.
Big Picture Mode comes up on the correct monitor and the game still does not.
The correct monitor is set as Primary, but in display settings shows up as Display 2.
The incorrect monitor is shown as Display 1.

Have the same setup and the same problem. Have to disable non-primary monitor to launch a game which is kinda annoying.

@focus_karl Big picture mode does not fix the issue. Game always runs on the monitor Windows 10 identifies as monitor "1", even though monitor "2" is selected as my "main monitor". These monitor designations of "1" and "2" cannot be changed by the user, they are assigned by the OS. The only thing the user can do is select which monitor is considered the "Main monitor". For most games and programs this isn't an issue, while this is not the first game I have had this issue in it is the first where it didn't also give me the option to select between monitor 1 and monitor 2.

I will be refunding my copy as this makes the game essentially unplayable on my setup, I'll watch this space and consider repurchasing once this is fixed.

Potentially relevant: https://www.froyok.fr/blog/2018-01-ue4-specify-default-monitor-at-launch

Also found this line in the Game.ini but changing it does nothing
SelectedMonitorIndex=0

I found a solution for the game launching in the wrong screen.
Open the shortcut properties that launches the game.
Append this string to the end of the target:
-game -WinX=0 -WinY=0 -FULLSCREEN

The string should be outside the quotes so that your target looks like this:
"D:\my games\Battlefleet Gothic - Armada 2\BattlefleetGothic2\Binaries\Win64\BattlefleetGothic2-Win64-Shipping.exe" -game -WinX=0 -WinY=0 -FULLSCREEN

I have an slight edit on Medereys' solution.
For Steam users you have to do it a bit diffrently to make it work:

  • Go to your Steam library

  • Right click on Battlefleet Gothic: Armada II

  • Select "Properties"

  • Select " Set launch options" in the tab "General"

  • Paste the text between the quotation marks ( Don't copy the marks themself) in the pop-up window "-game -WinX=0 -WinY=0 -FULLSCREEN"

  • Select "Ok" and "Close"

  • Now launch the game and have fun on your main screen!

I hope this fix will make a lot of people happier and works for everyone. This fix is also posted on "Battlefleet Gothic: Armada II > Technical Support > Topic Details" By the FHI Help Desk.

Cheers,

Dark0wnt

@medereyes Thank you very much! That does the trick.
Btw, if you launch game from Steam you can add this starup parametes by right clicking on the game name then properties than Set Launch Options. Copypaste this "-game -WinX=0 -WinY=0 -FULLSCREEN" to the text input without quotes.

@heretic77 said in Issue with game launching in wrong screen (for multiple monitors).:

@medereyes Thank you very much! That does the trick.
Btw, if you launch game from Steam you can add this starup parametes by right clicking on the game name then properties than Set Launch Options. Copypaste this "-game -WinX=0 -WinY=0 -FULLSCREEN" to the text input without quotes.

Topic is a bit old but having the same problem as of now... This little trick does not work for me. All my steam games still open up on the left monitor.

The shift+window arrow key does not work either.. Switching monitors around did not work. Yes I am in windows mode. I have been searching for the last week online hoping to find a fix. and nothing works..

One post had a fix where the guy said he had to fiddle with his Nvidia Control Panel to get it to work but he never said what he did.

set up is 3 monitors with a display resolution at 5760x1080 and Nvidia is set for Maximize 3D performance I play my games in 1920x1080. Game opens up on left screen off centered.. I have to drag to center screen, pick a lower resolution click ok than pick 1920x1080 again to get it to centered on center screen.

A fix on this would be great for all of us with multiple Monitors