How to install SpintiresMod v1.6.9 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!

The latest version of SpintiresMod is v1.6.9. | Direct Download | Latest as of game ver. 18/01/29

If you've had Spintires Plus in the first game (Spintires 03/03/16), you might remember you had the 3 files and 1 recources folder. This time, its an executable program.

0_1517465940545_597ad007-bfbb-4179-942c-56ba14865073-image.png

Once you have installed SpintiresMod with the setup, it will launch. On the top left there is a box that says Mod Settings. Click that. Then, this window will appear.

0_1517466032327_698ddb03-559f-49ac-b331-0861adfd16ed-image.png

Click Install... on the right under Spintires Mudrunner Directory. Another window will appear that shows all your folders and drives. Navigate to This PC/Local Disk/C:/Program Files x86/Steam/steamapps/common(or wherever you have Steam installed on your drive(s). In common, select Spintires Mudrunner and click Ok, then click Apply and Ok on the Mod Settings window.

0_1517465270836_768a1581-8a6c-4726-99c3-59d86b2b1172-image.png

And you're done!

In-game, you will have a new button in Settings at the bottom that will say Mod Options. That's the in-game Mudrunner Plus Config.

last edited by A Slice Of Pizza

@A-Slice-Of-Pizza
You need to use wildcards or more generic terminology. Steam is NOT installed in "Program Files" on my PC, it's not even on my 😄 drive...

@mexican_420 said in How to install SpintiresMod (Mudrunner Plus) Enable Dev tools, map select scroll bar, battery winch, and much more!:

@A-Slice-Of-Pizza
You need to use wildcards or more generic terminology. Steam is NOT installed in "Program Files" on my PC, it's not even on my 😄 drive...

personally i think its simple and helps anyone out struggling ... STEAM IS installed on my c-drive and is for most no need to start picking out little things like that ... its a general help guide am sure he could of explained in more detail but there are videos out there for that he did point out (or wherever you have Steam installed on your drive(s) so i dont see the problem ...

last edited by shuffy

Mexican, did you miss this?

"Navigate to This PC/Local Disk/C:/Program Files x86/Steam/steamapps/common**(or wherever you have Steam installed on your drive(s).**"

last edited by Digital X

Apparently I did miss that bit...
Sorry @A-Slice-Of-Pizza

Anyone know if there is a way to get this to work with the new update? Once I got the DLC my modloader went away. 😞 I tried re-installing but still no luck. Any assistance would be greatly appreciated. Thanks!

@pix3lmonkey By screenshot in Valley announcement disccussion, its still works.

@alpscruiser said in Spintires: MudRunner - The Valley Is Now Available!:

now the mzkt can do what he is made for

alt text

@joridiculous what version of the mod are you using ? Mine doesn't seem to work anymore either.

@gumbootgambler this is what i was wondering too. does it depend on the version being used that might be causing the problem? i know few people are not having any trouble with their STMR mod, but most are. so the next step in this would be the versions being used.

@8up-local
V1.6.6 here afaik
Whichever the newest pre-DLC version is/was.

Im testing 1.6.6 and still no luck getting it to work

i am running 1.6.7 and it is working fine. id didnt even go away after the update.

ok and i am on 1.6.6 and have issues as well. i think we might have something here. opinions?

i know this is probably a site that most modders hate but this is the only place i have found 1.6.7. if this is frowned upon i apologize, just trying to help out.
https://stmods.ru/spintires_mudrunner/materials_for_game/spintiresmod_exe_by_alexnez_for_mudrunner/

@gabe I've tried 1.6.5, 1.6.6 1.6.7 (the version you've listed here)
Nothing is working. I wonder if it has something to do with a the file path changing with the update. Keep us posted if anyone has some luck with this.

ok on my other computer my son plays on he is running v1.6.6. it is still working. just fine. so its not that.

1.6.6 was working but after today it stopped. so i got 1.6.7 and i cant get it to work

I had 1.6.7 installed pre-DLC. It stopped working with the DLC update. I also noticed that the DLC update deleted the d3dx9.dll(that gets installed when you install STM). Tried reinstalling 1.6.7 and installing 1.6.6. Neither one works.

There's also some weird shit going on with STM and the editor now too. If I try to open the editor with the STM launcher, and without the 4gig patch, I get.
0_1518576169932_steamerr.PNG

If I try to open the editor after uninstalling STM, but with just the 4gig patch installed I get this.
0_1518576338298_steamerr2.PNG

Basically the 4gig patch doesn't work with the editor now without also having STM installed with it. And/or STM doesn't work with the editor without also having the 4gig patch installed. I've already verified the integrity of everything(editor and game). It's all good according to Steam. WTF? I just wish everything worked like it did before today. I'm not seeing how some new level is worth dealing with all this broken shit. Of course I haven't even had a chance to play it. I've been dealing with getting things just to work right all day. Maybe it's so good it's worth all the trouble. Somehow I doubt it...

last edited by MudHappy

@mudhappy my editor is messed up too.. different from yours my 4gig patch seems okay but I get this. Damn this update!!

0_1518580076450_editor errors.JPG

Thanks @Gabe for linking to that site. Its the only one I've found v1.6.7 on too... Hope spinitres.nl updates that.

@Digital-X, you say in your signature you are a new writer of spintires.nl? Could you upload the folder?

last edited by A Slice Of Pizza

@PiX3LMonkey @joridiculous
I‘m not using Mudrunner Plus. It’s also not working on my PC.

I do it the old way - JSGM Mod Enabler.

I think this was clear that Mudrunner Plus will not work after Update/DLC.

Wait for an update of the author.

@alpscruiser Weird thing is - The mod is working for at least 5 people that I know of. Not sure what's causing problems for some but not others. Thanks tho, I was thinking of trying JSGME again. If it's working for you that's good news

@gumbootgambler That is real wierd. I want it back also, will crush the Vally with the DT-30 😉

@alpscruiser I couldn't get JSGME to work in MP with custom map and objects... gives me thee ol' game files differ problemo interested to hear if anyone has had any luck with this. I hope that mod 1.6.8 comes soon 😤

@gumbootgambler said in How to install SpintiresMod (Mudrunner Plus) Enable Dev tools, map select scroll bar, battery winch, and much more!:

@joridiculous what version of the mod are you using ? Mine doesn't seem to work anymore either.

1.6.6 and it is not working. 😐
just d/l 1.6.7 and will try that one.

Editor is working fine running from Modrunner though. (IF the 4bg patch is part of modrunner i guess i use it, if not. I dont)

I wonder? What files is STMR installing in mudrunner folder? Only the d3d9.dll?

last edited by joridiculous

@joridiculous Yeah as far as I can tell it only installs the d3d9.dll file. I have a hunch that the problem lies within that file as the mod needs it. It's a direct X file btw.

Question: do you have any other files in there with d3d9.dll ? d3d9.dll 43 or d3d9.dll 44 ? I personally just have d3d9.dll but I know two other people that have d3d9.dll 43 or d3d9.dll 44 in there and the mod is working for them.

@gumbootgambler Nope. Just one d3d9.dll
(Also just figured out i forgot to "install" the dll from 1.6.7 to mudrunner. Not that it changes anything though ☹ )

d3d9.dll d3dx9_43 is all you need

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.