SpinTiresMod How To Install and Discussion

No luck. i'm dead in the water. even after a full reinstall

It still works in the game but not the editor

@pix3lmonkey said in How to install SpinTiresMod (Mudrunner Plus) Enable Dev Tools on ANY map **SpinTiresMod Discussion**:

It still works in the game but not the editor

yeah if you revert back to an earlier version..But I want it for the latest version..Sigh...LOL

@pix3lmonkey said

It still works in the game but not the editor

i have the opposite results, the editor is working, but not the game, weird.
_and after trying all of the fixes listed,
_to include like you've done (pix3lmonkey) i wiped all mudruner files out . the game , the editor, the Mod. killed all the appdata files as well.And I Did a search, (c:)drive, of all of the mudrunner names i could think of, and deleted all those too..
__reinstalled it all, and all my maps are fine, (no third party models)..
__ the Editor is working.
_the only way the game mod is working is in offline mode. and no matter what combo i use , the Mod Enabler is not showing any files in it. which leads me to believe that the Mod is not linking with the Workshop or steam at all..
__Could someone that has it 'working' please attach screen shots of the placement of the files. and of the finished results. there are just way too many combos of information out there, i'm really curious as to what is considered working, and to what extent of working (if your able use the step recorder to layout the process, it would be a big plus)..
__i have joined a few of the russian groups, and follow them as best as possible with google translate. and it seems that the mod is dead for the time being.

edit: just saw that both the game and the editor were updated 1-23-2019
675010 Game Spintires: MudRunner about 23 hours ago
716020 Tool Spintires: Mudrunner - Editor a day ago

Pavel [developer] 7 hours ago
Incredible work, super impressive! Very well written! I can't promise any major updates to the Editor, but if there are any small things that will make it better, let me know!

xxxxxxx [author] 6 hours ago
Thank you for your kind words, Pavel. I saw that at least a couple of issues in the Editor were fixed in this morning's update, so I can tell that you're still on the job. 🙂 But since you ask for "small things", here is one: right now it is too easy to accidentally select "Reload" instead of "Rebuild Terrain" in the context menu. A confirmation dialog on Reload would be helpful. 🙂

last edited by rufus

@rufus I would love to have your problem. what is your current setup to get the mod editor working with the modloader? What version are you running? Is your editor set to Beta or not in the tools.. i'm dying without the ability to work on my maps.

The fix I mentioned a couple posts ago works for all my friends and myself. So feel free to try that method. Any feedback is appreciated!

last edited by A Slice Of Pizza

nice how we are figuring this out ourselves. seems like a job for the mod dev you would think. 🤔

@bigboyzback said in How to install SpinTiresMod (Mudrunner Plus) Enable Dev Tools on ANY map **SpinTiresMod Discussion**:

well I hope not..but I am beginning to think the DEV for this MOD has abandoned it...but I will never give up hope...

i question if the Dev is actually the Dev for the mod, but i will fully admit i have always questioned who Alex is for a few years now. i for one am not surprised though.

@A-Slice-Of-Pizza I can get 1.8.2 to work for the game.. just not the editor. I also tried your method last night but didn't have any luck. I'll keep trying.

@PiX3LMonkey for me it is working only in the game too, for the editor, no luck 😕

Thanks @A-Slice-Of-Pizza. I did finally get 1.7.6 to work for me in the editor. Its still not a 100% fix but it at least allows me to continue working on some of my stuff. It doesn't seem to have access to the same memory pool as 1.8.2 had so some of my distribution maps and water features dont compile but I can at least do some terraforming until 1.8.3 comes out (fingers crossed).

Also as a side note. I'm not sure if its just my current install with 1.7.6 but i'm currently not able to drive my truck outside of any 64x64 sized map. I'm playing around on a 96x96 and I keep hitting an invisible border on all sides of the map around where i'd expect 64x64 to be.

last edited by PiX3LMonkey

I just hope that the Update 1.8.3 actually comes out.... It's never taken the Dev for this APP this long to Update it.. I am fearing that he may have abandoned it... But I always fear the worst and hope for the best.. Lol

All we can do for right now is figure this fuss out ourselves

@bigboyzback I thought it was really interesting that this same guy (Alexnez) released content for Spintires way back in the day on spintires.nl . The guy has been around this game for a long time so I don't think hes going anywhere.

well day what ever it is and still no update...I am really thinking at this point..he has abandoned the MOD..

@bigboyzback - It looks like he is still active on this. Looking at the build number he is probably working through bugs and making sure everything works before releasing it as any good dev would. I'm just as anxious to get back to work on my map as anyone else but i'd rather wait and have something that works than to get a rushed build that is unstable.


last edited by PiX3LMonkey

I was able to get a drop of 1.8.3 beta4 from those guys but unfortunately it looks like the editor is still not working. Fingers crossed that the final 1.8.3 will be out soon.