SpinTiresMod How To Install and Discussion

@twisted_xj said in How to install SpintiresMod v1.6.8 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!:

does anyone have a link to the 1.6.8 yet?

there is a link a few posts above, but here you go. i am not a fan of the site, but it seems to be the only place to get it at the moment.

STMR mod 1.6.8

last edited by A Former User

@8up-local after update i didnt do nothing else but take out mods with no names that made my game to stop glitching i didnt reinstall the game. 1.6.6 stopped so i took it out of my computer then put in 1.6.7 and take it out and put in 1.6.8. i down loaded it and open it. mudrunner was in there just like it was in 1.6.6 when i downloaded it back when it worked i just cant figure out if im doing something wrong

@motohead74 have you tried reinstalling 1.6.6 or 1.6.7? i did not uninstall mine. i just installed the new version over the old one.

@8up-local i will try it

@motohead74 try deleting the old d3d9.dll before installing 1.6.8

@gumbootgambler it worked but now when i open the game it says downloading mods on the right side of screen and my game is glitching

@gumbootgambler never mind bro i just had to restart the game but i have DEV tool now thanks man for the help

@8up-local i got it workin bro thax for the help

last edited by motohead74

@8up-local - This is what I've observed.. I have tried this on 4 different machines. I cannot get this to work on 2 of my 4 machines, using the same method.


Clean install or Upgrade install on Windows 7. You do NOT need the 4Gig Patch for this to work. Game version - Ver.18/01/29. Mod version - 1.6.8. I was able to do single and multi with custom maps + custom objects. Mod Options window shows up on the main settings screen no problem.

Doesnt work:
Clean install or Upgrade install on Windows 10 ---- Game version - Ver.18/01/29. Tried Mod version 1.6.6 and 1.6.8. Tried including and excluding 4Gig Patch. I could NOT get any combination to work under windows 10.

From my perspective it seems like this may be a bug related to OS. @GumbootGambler - For those users here that have configs that work, which OS are you using? Is there anyone here who has it working on Win10 Latest Update?

Win7 x64
Super dirty install has been on there forever and is clogged to death with odds and ends and leftover bits of everything 0.0
Need to bake it and start over, but I have sooo much crap on it...

i read where someone unistalled and reinstalled within the mod settings itself. where you set your folder paths. might try it. idk


Here's what I'm runnin:
This isn't a how to just what I've done. Don't recommend deleting your appdata and saved games unless you don't mind starting over

-Windows 7 64 i7 16GB Ram 4GB video card
-Mod 1.6.8 on STMR Version 19/01/29
Wiped all mudrunner appdata and saved game data then un-synced steam cloud
-with or without 4 gig patch
-Tried packaging up my maps zipped or unzipped and with JSGME as well.

I'm still experiencing massive FPS drop. No longer able to load custom rocks from DrGonzo's Rox Valley2.0 I tried the STMR Beta it seemed to help with FPS drop but from what I could tell it deactivated the mods and custom objects in MP. I might try and unsubscribe from all my trucks. Wipe and re-install again @shadowsincere can you confirm that unsubscribing in workshop helped with FPS ?

ok. so here's one more thing to look for.. In the SpintiresMod/Install folder there is a d3d9.dll file marked 2/8/2018. I had a win7 install not work until I MANUALLY copied that file to the root folder of Mudrunner to overwrite the older file that was there. Once i updated that specific file, the modtools magically appeared on one of my machines. Hopefully we will get to the bottom of the magic sauce soon. F****or anyone on Win10 with it NOT working, can you check the date on your d3d9.dll file AFTER installing 1.6.8 ModLoader. If its older than 2/8, can you try overwriting it with the updated .dll file from the SpintiresMod/Install folder.

@GumbootGambler Great! So far, only Win7 machines seem to be working.. Anyone here with a working Win10 installation?

@joridiculous said in How to install SpintiresMod v1.6.8 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!:

@pix3lmonkey yes. and i did the crazy thing of just running the installer, then uninstall / install the mod in mod settings.

Easy fix. 🙂 Everyone do that if the Mod Settings button in-game is missing. Just uninstall and reinstall game directory in SpintiresMod.

last edited by A Slice Of Pizza

so @joridiculous you're saying its working in Win10 specifically now?

@pix3lmonkey i am useing windows 10 on a GX-785-UR16 and it is up to date. it took my a bunch of tries to get the DEV tool in my game but it works now