SpinTiresMod How To Install and Discussion

another guy and i just ran mp on nix new map. both of us are running windows 10. also running MR mod1.6.8. the only thing is we couldn't select any modded trucks in the lobby. so we went ahead and started the game and was able to spawn in whatever truck we wanted. so we rode around in the Colorado crawlers and checked out the new map. so it can be done. shouldn't be that hard tho.0_1518870953297_20180217061919_1.jpg

@gumbootgambler It did for me but eventually it seem to be a waste of tiime to unsubscribe all mods.
Just go ingame > single player > manage mods. In the list at the right side delete all no name (blank) mods.
Not sure if you should restart the game but it did it anyways. So yes that helped to get my FPS problem fixed.

I use Windows 10 and the mod functions as it should with version 1.6.8 and the most recent STMR update. I do however, seem to be experiencing performance issues when using the D3D9 over ride function. If I use ReShade without the mod the game runs smoothly at a solid 60FPS, if I run the STMR+ mod without the over ride I get the same performance. When I use ReShade and the STMR+ mod together I get no more than 45FPS, even if I disable all of the functions within ReShade in-game, so its got nothing to do with the effects I am using. I tried with and without the 4GB fix and get the same results. Has anyone else experienced this? I have message Alex (the creator of the mod), but I don't know if he either sees this as an issue or he isn't looking to fix it. I haven't received a response either way.

I believe I read somewhere about STMod and ReShade/SweetFX not getting along very well, but don't quote me on it. Didn't really look into it as I don't use either of those visual mods...

@motohead74 said in How to install SpintiresMod v1.6.8 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!:

...what do i need to do to get DEV tool back in the game

It's a PITA, and somewhat pointless, but there's another way. Here's the step by step:

  1. Open Media.zip. Then levels.

  2. Copy game_proving.dds and game_proving.stg files. Save them somewhere safe. Then delete them from the levels folder.

  3. Make a copy of the .dds and .stg files for the map/level you want to be able to use Dev Tools while playing. Rename those .dds and .stg files to, you guessed it, game_proving.dds and game_proving.stg.

  4. Copy and paste the renamed .dds and .stg files to the levels folder in Media.zip.

  5. Start the game and go to single player. Then select proving grounds.


If you want to use Dev Tools for a different map/level, or want the default proving ground again...you'll figure it out. Also sort of needless to say...but like I said, it's somewhat pointless to do any of this. Because converting a different map/level to the proving ground just makes it the proving ground. So if you're wanting to use the map/level for any other purpose...not happening. No game progress, no saves, etc., etc..

last edited by MudHappy

@mexican_420 ah, cool. thanks for that info, it is good to know that they are possibly other people experiencing this.

i had to remove the file d3d9.dll from the game to get it to work i have windows 10 my son has window 8 and DEV tool 1.6.8 I had no problem putting it in his game

@pix3lmonkey i have windows 10 and it is up to date for me to get the DEV tool in my game i had to delete the file d3d9.dll after that it woks good and i have multiplayer modded maps everything works fine

I haven't been able to get the 1.6.8 mod to work with MP yet. I get the following error and it crashes when the second player joins. I had to uninstall the mod and use JSGME to use custom maps in MP. Start the lobby with a stock map and then add the modded map with JSGME while your both in the lobby. Mod works for everything else. Might need a patch still?

0_1518916619165_MP error.JPG

Thx @joridiculous. i'll update my link to google drive

I never updated after 1.6.5 and am currently having no issues with SM.

425MB+ update this morning. Looks like we're waiting on 1.7a now...

@mexican_420 the update this morning (795.6mb) is a hotfix, but yes STMR mod (ST+) is broken again. it is not showing up in my settings menu. looks like a bit of a wait. lol

Not on mine...
Nor @8up-local
Nor @FearWheels
Also is it just on my side or does the Workshop also appear to have sh*t the bed??
Gonna restart Steam and check again...

EDIT: confirmed that update nerfed the Workshop...

EDIT: Workshops were nerfed all over Steam, not just Mudrunner. Disregard this post.

last edited by Mexican_420

@mexican_420 i uninstalled and reinstalled the mod. open the program and go to mod settings. uninstall and reinstalled there and it is working for me now.

@8up-local said in How to install SpintiresMod v1.6.9 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!:

@mexican_420 i uninstalled and reinstalled the mod. open the program and go to mod settings. uninstall and reinstalled there and it is working for me now.

Confirmed, thanks @8up-local