SpinTiresMod How To Install and Discussion

Shouldn't have opened my mouth....as of this morning 1.6.5 is not longer working. Did a clean install with the newest version and everything is working as it should. One thing that is off though is I have to run Mudrunner through the Spintires mod....if i run it from the desktop shortcut for the game itself it doesn't work.

last edited by Fatboy

no issues here, i can start form both. strange how people can be affected differently with this stuff.

i got home and started the game and i seen it (update) i was like o no. i just got all this working good again. but i dont know y it all still works. so im just going with it and i hope it keeps working

same issue as @Fatboy now. If I start Mudrunner from the STMod 1.6.9a launcher, mod tools work. If I launch directly from the game shortcut in Steam, no mod tools.
Weird because the mod tools were working fine earlier when I launched from the Steam shortcut...
Tried uninstalling & reinstalling again, but problem persists.

last edited by Mexican_420

Looks like this latest update broke v1.6.8

@mexican_420 I'm on Spintires Mod 1.6.9 and version 18/01/29 Everything seems okay so far but haven't tired MP. I did uninstall and reinstall the mod from the mod settings because I read that on here.

I see 1.6.9 but when i download it and try to install Windows 10 says it's unsafe and blocks it.

@JustaFordGuy Where did you download it from?
ps, I like your username 🙂

The link on the first page of this thread.


@JustaFordGuy it is perfectly safe, run it anyway. Works fine on my PC and Webroot doesn't say its a virus or anything.

Cool, I'll give it a shot.

@a-slice-of-pizza said in How to install SpintiresMod v1.6.9 (Mudrunner Plus) Enable Dev tools, battery winch, and much more!:

@JustaFordGuy it is perfectly safe, run it anyway. Works fine on my PC and Webroot doesn't say its a virus or anything.

Seems to be working fine, Thanks.

No problem man. Always here to help anyone when everyone else won't bother.

I downgraded from 1.6.9 to 1.6.8 earlier today(trying to fix my game after today's "temporarily totally fuck your game up BAD"fix) and 1.6.8 still worked for me(didn't do anything to help fix my game though). Went back to 1.6.9 just because why not? No reason not to. And no, it wasn't just the workshop that quit working for me with the "fuck"fix. I couldn't use custom maps either. Both that and the workshop suddenly fixed themselves for whatever reason.

There's one thing that's now broken for me with both 1.6.8 and 1.6.9 though. If I start the game from the launcher, or the MudRunner4GbPatched.exe, while Steam isn't already open it will only start the game in offline mode. STM won't start Steam up in the process of loading the game anymore. If I open the game from the default Mudrunner.exe, or the desktop shortcut to it, it will start Steam up first(if it's not already running).

Hint: About that MudRunner4GbPatched.exe. You can find it in the C:\Program Files (x86)\SpintiresMod\Install\Spintires Mudrunner folder. Drop it in C:\Program Files (x86)\Steam\steamapps\common\SpinTires Mudrunner and make a new desktop shortcut to it. Now you can start the game with the 4GB patch installed without the launcher(or the other janky 4GB patch installed). Same goes for the editor. Substitute editor folder names for those above, (actually, installing STM automatically installs the SpinTiresEditor4GbPatched.exe in C:\Program Files (x86)\Steam\steamapps\common\Spintires Mudrunner - Editor Beta, so skip that step). I noticed the new 4GbPatched.exes showed up with 1.6.8.

last edited by MudHappy

One small detail you should notice there is that if you start Mudrunner by right clicking the Steam tray icon, it runs the stock Mudrunner exe and the menu in-game shows a version number one iteration newer than if you launch the modded exe. Does for me, at least, and no mod options if launched via the stock exe but working with the modded exe.

Windows 10 Defender doesn't like the file for some reason but I ran it anyway and it works fine. (Thanks again Slice of pizza).

@joridiculous ok I don't get it before I was running 1.6.9 and my version said 17/12/11 and I couldn't join anyone on MP and no one could join me, then I downloaded that link you provided and installed it and boom everything worked and changed to version 18/01/29 and everything worked on MP , I can join and people can join me....However, when I turn the game off and back on again it changes back to the 17/12/11 version by itself and nothing works again? wtf is going on

Sorry to hear that @SmarOneNine, I'm not having that problem. At least, not yet. How are you launching the game? There are many ways to launch it, Steam on the taskbar, SpintiresMod, desktop. So you might not having the shortcuts to the same .exe and that's messing it up? Just a wild guess.