Stuttering of the Game Engine for Optimization Request! (New Update 22nd Dec)

Problem with the game:
Insane Stuttering and FPS Dropping no matter the Settings.
High Settings - Stuttering and FPS Dipping Highly Frequent
Medium Settings - Stuttering and FPS Dipping Mediocre Frequent
Low Settings - Stuttering and FPS Dipping Mildly Frequent

PC Specification Used in Running this Game
PC: MSI GE72VR 7RF - Laptop
OS: Windows 10 64bit - Creators Update
RAM: 8GB
Resolution: 1080p 1920x1080
CPU: Intel Kabylake Core i7-7700HQ
GPU: GeForce® GTX 1060 with 6GB (Driver 417.35 Version)

Suggestion by the Community:
-USEALLAVAILABLECORES on Steam Command Launch does not help with the Game Performance.
Delete Insurgency Folder from Localappdata, does not help with the Game Performance.
Upgrade Ram? Does NOT act as a Solution when SQUAD which Utilize the same Game Engine, Unreal Engine 4, had zero Stuttering and issue running at High Settings.
Reinstall Driver? Done that and still does not Solve the Issue.

How is this game having such Issue with its Optimization when it has a Positive Review Rating?
The Likes of Battlefield I & V, Final Fantasy XV, ARMA 3, SQUAD and Rising Storm 2: Vietnam had no issue with the last 2 using Unreal Engine 4 and 3 respectively has Zero Issue running at High Settings with no Stuttering Pre and Post Launch but this game has?

Edit: 22nd December Update
New Update
Low Settings: Highly Playable
Medium Settings: Playable with Minor Stuttering
High Settings: Slight Playable but Frequent Stuttering

Keep up the good work on Optimization

last edited by Spensern

Try turning off preload textures and texture stream pool

@Leopardi Done that so long ago and it does nothing.
Pagefile disabled also does nothing.

last edited by Spensern

Try selecting the "Low" preset, run it, see if it works. Then adjust other settings (one at a time ofc) to your liking until performance degrades too much.

Also, increase process priority, i suggest doing so via registry (since EAC interferes otherwise):

create file ins.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\InsurgencyClient-Win64-Shipping.exe]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\InsurgencyClient-Win64-Shipping.exe\PerfOptions]
"CpuPriorityClass"=dword:00000003

Execute the file, adds some info for the .executable to the registry, enjoy high priority. (works with every .exe)

last edited by Feuerholz

@feuerholz I mention Low Settings as above on Main Post that it doesn't work.
I fiddle with every settings on Custom it still doesn't work.

Now I've tried testing with your .reg and the game only at low it works but to a low frequent stuttering degree that it could be considered "Playable".

Have you tried deleting the contents of the following folder?

%appdata%/local/insurgency/saved/config/windowsclient

First search for %appdata% in your windows search bar. Then go to the local folder...and so on.

That fixed the stuttering for me.

@musicnote I noted that on my Main post under "Suggestion by the Community: Delete Insurgency Folder from Localappdata, does not help with the Game Performance."

22nd December Update Edit
New Update
Low Settings: Highly Playable
Medium Settings: Playable with Minor Stuttering
High Settings: Slight Playable but Frequent Stuttering

Keep up the good work on Optimization

yeah now i know im not the only one who also face these problems

I have a good system and I get similar problems. My next step is to install the game on a SSD instead, but I never had any problem with other heavier games on a normal drive.

Specs:
W10 64bits
i5 6600K
16G RAM
GTX 1070
Asrock Pro4S Z170
Playing on a 21:9 screen

@feuerholz can you elaborate on hoe to do this? Since I'm messing with my registry i want to know EXACTLY how to do this, any help would be greatly appreciated, thank you.

@RedKap
Not much more than what i described above. You create a file with the .reg extension, edit it and copy-paste the content i posted. Then you execute this file so it adds the registry keys automatically.
Alternatively you can add the keys to your registry manually.

It then tells windows to set this process to high priority on launch.

Today noticed when playing on an official server, the graphics are fine. No stutters. Playing local, no stutters. But playing on a community server, I get micro stutters no matter what graphics setting it is set at.

My system running at 1080p:

i5-4670
8 GB RAM
RX 560
installed on SSD

Certain settings drastically lower average fps and introduce stutter. Shadows above medium drop my fps from 130-150 to around 100 with introduced stutter on my system with a 1080ti and i5 4690k at 4.7GHz and 1440p resolution. Scope set to PIP has a drastic effect on fps as well, along with some of the lighting-related settings lower down the list. Try playing around with settings individually to see how it alters performance, the packaged low-med-high etc presets aren't optimized, and you can run certain things much higher for a better looking game with much better performance

last edited by schoenzy

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.