Jittery after the new update, not to mention FPS drops

After the update on December 22nd, when I aim down sight, its jittery and I drop frames. I have a great PC, specs are below.

I run a 144hz monitor, and i get massive screen tear and jitters at 160fps, makes no sense. My graphic settings are: Textures: High - everthing else low EXCEPT Post-Processing is on Medium. Ive tried EVERYTHING to fix ti to no avail ( delete that folder in local app, use cutom start parameters in Steam). The ONLY thing that makes it playable it to play everything on LOW, but who wants to do that? no one.😕

I feel like every single game made on Unreal engine takes like a year to optimize too which sucks for me i suppose 😢

I truly hope the next patch is solely focused on fixing performance issues because this latest one didn't fix it for me.

The game is so much fun BUT this terrible performance just makes not fun. Is anybody having the same issue with a 144hz monitor?

I still have playable fps, but I definitely dropped from averaging 90 to averaging 50-60. No changes in any of my settings, just went to sleep with around 90 fps and woke up to the update which dropped to 50-60. So something happened in the newest update...

I encourage you to try playing competitive matches (5 vs 5). Maybe it's not your favorite gamemode, but for me it's the only way to enjoy the game. The performance difference between casual games and competitive games is huge.

I have noticed something about this game strange. During the "Match Warm Up" the game performs GREAT, sooth as could be. BUT when the match actually begins the choppiness and jitters begin. It makes ,me think the bad performance has to do with other players somehow. Also the close I get to players the more jitters I get.

@redkap That's right. That's why performance is much better in ranked matches.

Hi All,

I am experiencing stuttering of the model characters during gameplay. Like a super fast stuttering of the models when running or moving. It sometimes goes away if the model if further away. Anyone else experience this? Its incredibly annoying and ruins the gameplay a little. Other than that the game runs super smooth. Seems with my high end pc this should not happen as other people dont have that problem. And its not the frames skipping its the actual player models. Makes no sense to me...

7700k 4.4ghz
MSI 1080 TI
16 GB DDR4 RAM
860 SSD Samsung 500GB

yes I experience that. I feel as if , the further i am away from my teammates or enemies the BETTER the game runs. The closer I am the more jittery it feels. Though, i have gotten used to it , unfortunately. I hope they fix it.

Ok, so i feel like the game is running better now. not sure what happened. i wonder if the issue was on my end the whole time.

@scorchedpaint said in Jittery after the new update, not to mention FPS drops:

Hi All,

I am experiencing stuttering of the model characters during gameplay. Like a super fast stuttering of the models when running or moving. It sometimes goes away if the model if further away. Anyone else experience this? Its incredibly annoying and ruins the gameplay a little. Other than that the game runs super smooth. Seems with my high end pc this should not happen as other people dont have that problem. And its not the frames skipping its the actual player models. Makes no sense to me...

7700k 4.4ghz
MSI 1080 TI
16 GB DDR4 RAM
860 SSD Samsung 500GB

I have the same shiver/jitter/shake ( whatever you call it ) of the character models too.
Interesting that it only happens in multiplayer games.

But , when i play a singleplayer mission the jitter gone.
So i think it´s a netcode problem, that NWI still could not fix, yet ( we all hope that they will get that fixed soon ) .

That might be connected to the hitbox and the actual position of the moving characters.
People from different places on the world play together on one server and their pings are different.
Every character move of each player and each bot ( coop ) on the map has to be transfered to each player simultaniously, which seems to be a very difficult task ( to make it look smooth and fluid move).

Therefore NWI should ask for professional help of other gamedevelopers who don´t have these problems in their games.
NWI´s actual netcode programmers don´t seem to be able to fix this problem on their own abilities.

So in the name of all unsatisfied players /customers :
NWI, please get external netcode experts to get the job done !

last edited by GSG_9_LIGHTNING

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.