Mouse clicks not registering 60% of the time

I have had this problems since the alpha, and it has not gotten better. Approximately 60% of the time, my mouse clicks are not getting registered. Going to shoot: nothing, trying to aim down sights: nothing, trying to kick a door: nothing. This has nothing to do with ping/latency, as it happens even in the training/offline mode. All weapon types are affected as well as fire modes.

I was trying to get a friend to join me in the game and he was experiencing similar things. The only thing we have in common is we both have Corsair mice, different models but the same brand. This does not happen in any other game or in the original Insurgency, as I've checked to make sure its not my specific mouse.

I enjoy the game and still play it, but 80% of my deaths have been from my mouse clicks not registering and it's infuriating at this point.

@marvelousbacon I definitely feel your pain as this does happen to me from time to time but I must say it is no where near 60%. It is actually quite infrequent for me but I have had several occasions of this in my 200+ hours in sandstorm. Just instances where say an enemy will hop through a window and I am already aiming on said person and I click the left mouse button and nothing happens which then usually prompts me to yell something like “FFS” or “Of course my gun doesn’t fire” at my monitor lol. Not sure why this happens but it most certainly does... Just wanted to add I have a good PC with good accessories and won’t play in a server with ping higher than 80 (it’s usualy in the 40’s for me). I also stay very aware of my current ammo/magazine/ROF situation.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.