Can't reach full throttle with Logitech G920 and H-Shifter (Xbox One)

I'm playing the game on my Xbox One and I use a Logitech G920 wheel with clutch and H-Shifter. Everything seems fine except that I can't seem to be able to achieve full throttle/power while in manual gearbox mode. If I disable the H-Shifter and Clutch option and use the automatic gearbox the trucks are definitely WAY more powerful/faster.

The problem is SO bad that I can't actually play the game using the manual gearbox mode: using the D-538 on "The Ridge" map for example can't go uphill on the asphalt road. The engine just makes a lot of noise but the wheels won't spin at all (not free spin or anything - it just sits there). Leaving the trailer behind it barely goes uphill in 1st gear only. Again, switching the manual gearbox option off and using the same wheel and pedals seem fine.

Can someone let me know how I can fix this? This makes the game unplayable atm which is a shame 😞

Let me know if I should make you guys a video or something since I don't think any other debugging option is available for me using my Xbox One

last edited by Forces

@zeusent, I found the same bug on PS4 using the Logitech G29 wheel, pedals and shifter! I have a thread here on the forum as well as a YouTube video demonstrating the problem. Apparently you never got a reply or found a solution? Too bad, this really diminished the game for me!

Community Moderator - MudRunner

Here is the link
Trouble with G29 and K-8400
@Diggydog you added it on the general section wich wasnt the right one, let me move it to here and change its name, both issues seems to happen on consoles

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.