Driveshafts Not Working

Just today I wanted to step up my level of detailness with my mods, so i tried to make a driveshaft. Things didn't go so well, so I'm coming here.

This is my code (which i am sort of confused with)

	<!--<Shafts>
		<Shaft SocketPointA="FrontDrive" SocketPointB="FrontDrive" />
		<Shaft SocketPointA="RearDrive" SocketPointB="RearDrive" />
	</Shafts>-->

This is my driveshaft and bone:

(The white stuff inside is the bone which was rotated with the driveshaft to that rotation.)

0_1547406522055_driveshaft.PNG

@RiskyWisky
AFAIK your SocketPoints should be your bones (at each end of the driveshaft). Also the "<!--" & "-->" would indicate that the "shafts" section in your XML are commented out.

last edited by Mexican_420

@riskywisky so far I know, that code is for the driveshafts the game adds, you don't have to model them.
Thats why an UAZ has the same shaft as an Ural

Or this was an other code

last edited by wrangmog

Yea now i get the socket points. @Mexican_420

@wrangmog i think they just use the same model in the truck .x

Made 2 bones (1 on each end) and nothing rotates. also fixed the code to:

	<Shafts>
		<Shaft SocketPointA="FrontDrive" SocketPointB="FrontDrive001" />
		<Shaft SocketPointA="RearDrive" SocketPointB="RearDrive001" />
	</Shafts>

@riskywisky I still believe it doesn't work like that, but let me know. Because i tried it ones and I believe someone said it didn't work like that

So your saying just delete my driveshaft and see if it works? @wrangmog

@riskywisky I cant remember how it works, but I believe someone told me that these are hard coded or something. I could find some trucks with working shafts, but they are the standard shafts. But I could be wrong, cant remember exactly😅

I noticed with some of @Spun's trucks the driveshafts do look the exact same as the ones on the stock trucks.

Still... nothing. All of the code is in place but there is no driveshaft in game. I still have the bones in my 3ds max file aswell

@RiskyWisky you can't add your own driveshaft in game, you could back in spintires with the ST+ (All my mod had them) now you cant, you gotta do the Focus way, overscale your Diffs or dont model the input shaft

theres another way wich is with the rotators, thats how I animate the Axle shaft in the axle Knucles on my newer mods, but you gotta figure that out to work with your mods, I've show to people how to make that but something in max or with the way they make them makes them not follow the axle right (nope its not hierachy) blender seems to work a bit diferent with some stuff that 3dsMax seems to complicate more

I know how to do a rotator and will do that. How would i do it the 'focus' way? By the way thank you for the detailed response (as always)

@riskywisky dont model the input side of the axle diff just build the cover side and let the shaft be the imput side, the the chevrolet_k5_blazer.xml truck in the editor in the directory dlc->usa->classes->trucks, instead of _mods

see how the axle has just the front part modeled but the rest is almost flat, well try to mimic that with your axles, that way it looks like the right size despite being a huge shaft
on a side note, spun and friends dont animate the shaft of their trucks (as far as i know)

@forces said in Driveshafts Not Working:

theres another way wich is with the rotators, thats how I animate the Axle shaft in the axle Knucles on my newer mods,

Hmm, I'm gonna have to check this out. Curious to see what ya did. What mod did you do this on? I didn't know you can do that. Is it because of the new rotator how it go with the rpm of the engine? Interesting...

last edited by Tattoo

@Tattoo check the 59 chevy task force apache from @SmarOneNine the major issue is that I animated all of the steering component with cdts so the engine revs increase making rpm controlled rotators spin even when parked , I wish localhost could help me out and disable the feature just like he did for me back with ST+

@riskywisky I didn't understand the tag on the post with the fans, I know rotators can ben used for fans🤔

@riskywisky said in Driveshafts Not Working:

Rotators can be used for fans and what not @wrangmog

^^

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.