Battlefleet Gothic: Armada 2 - Second Beta Known Issues

Hello Admirals!

Please find below a list the current known issues. Please keep in mind that this is a Beta and we're still working on ironing out some technical issues and balancing. For this reason, we would love to hear your feedback about the game!

Launching the game
If you are using Windows 10 and Fullscreen display mode, there is a possibility that the display will be corrupted with green flashes.

This is an NVIDIA-GPU issue sometimes with Unreal Engine Games.

Fix: Please use windowed or borderless window display to avoid the issue
We have noticed an issue on the first launch of the game with some anti-virus programs (such as Avast). The issue will only appear at first launch and we recommend rebooting the game if you encounter an issue upon launch.
If the game crashes at launch, delete your local folder in AppData and verify game file integrity on Steam.
Do not change your local files or it could create issues with the Anti-Cheat system.

General

  • If you are sent back to the main menu after a bit of time in the battle menu, please verify the integrity of your files on Steam to fix the issue (this is linked to the Anti-Cheat)
  • If you unplug your sound device during the splash screen, the game will freeze. You can left click to get to the main menu if this happens.

Stability

  • Do not put a ! in your savegame name, this will cause the game to crash
  • Let us know if you experience a crash – please report it on the technical forum on the steam forum, or on the focus forum with the associated dump file in your save folder

Text
There are several known issues with the texts displayed in-game

  • There are a few remaining texts issues
    o Some texts start with an asterisk at the beginning
    o The Alpha Legion is displayed as #N/A in the skirmish mode
    o The Ork Komando training upgrade has the wrong description
    o Some values are still not properly displayed
    o The VO lines don’t match the subtitles during a part of the Imperium tutorial
    o The Point of Interest “Listening Post” in the Exeltra Minor system has issues on its values.
    o The “Blessing of vaul” upgrade doesn’t have its value displayed properly

Other

  • There are some freezes linked to the UI display (for example: Custom Fleet Panel will take a few seconds to load up)

Prologue

  • You cannot save during the prologue, you have to play it all the way through (this is not a bug)
  • During prologue 1, when doing the “perform a boarding action” with your boarding torpedoes, there is a rare possibility that you will put the enemy ship in a drifting hulk state if you have rammed it before. Please restart or bypass the prologue if that’s the case.
  • You can block yourself if you destroy the blackstone fortress before it loses its shield
  • There is a slight delay with the subtitles during the prologue cutscenes
  • During the second Prologue mission, when Captain Tor Garadon speaks to captain Harbride, the associated VO line will not be played, and the player has to manually click on “next”.

Multiplayer

  • All profiles have been reset for Pre-Order Beta 2
  • The game will allow more time for slower players to connect to a game before invalidating it
  • Fixed multiple connectivity issues
  • Improved netcode to reduce desynchronization issues
  • You can now ping on the map in 2vs2, which will be shown to your ally

Battle

  • In the battle menu, there is no tooltip over the locked skills and upgrades. You must play in ranked to unlock them properly
  • Sometimes the portrait that you earn after a multiplayer battle will not be the same as the one displayed in the score screen
  • Multiples fixes have been made on the connectivity and desynchronization, let us know if you encounter an issue with the matchmaking.
  • In multiplayer, the disruption bomb has a smaller radius than its actual area of effect
  • In multiplayer, the guest can see texture issues with the fleet color Emperor’s Children and Death Guard
  • When the augur probe skill collides with a ship, it will be displayed in its unit circle
  • The augur probe skill can collide with allied ships
  • In multiplayer, sometimes the tentacle skill on tyranid ships can go in the wrong direction
  • The tyranids use the imperium model for their augur probe skill
  • Guest can have some visibility issues in multiplayer
  • In the battle menu, the animation of a skill/upgrade unlock is played each time you arrive there
  • In 2vsAI, if the guest presses “back” when the host is selecting the AI, the game will not launch correctly
last edited by Jellyfoosh

Getting anticheat error for opengl32.dll. I have the latest nvidia drivers.

alpha legion being displayed as N/A actually makes sense

@jellyfoosh said in Battlefleet Gothic: Armada 2 - Second Beta Known Issues:

There are some freezes linked to the UI display (for example: Custom Fleet Panel will take a few seconds to load up)

So i had this happening for a game and when i exited it, it caused my entire pc to freeze, requiring a hard reset to fix it.

Hi, I just wanted to mention my issues, but you have covered them in your list, so I thought i'd comment here rather than add another thread, but maybe it can help give you an idea on how many people suffer from which ones etc.

Issues: Ran at epic resolution. GTX 970, 32gb Ram, Intel I7 4ghz

-Text boxes are basic and look like CMD lines. = fleet color :
-Text is sometimes incorrect like: N/A

-Selecting fleet builder causes delay and stuttering on game.
-Selecting view ships or create fleet causes delay and stuttering on game.
-Takes long time for textures to load on ships.
-If a ship is selected in fleet builder then viewed in 3d, weapons are selected in green but cannot be deselected until changing ship with arrows.
-Viewing ship can sometimes cause complete system crash suddenly, restart required.
-Viewing ships in fleet builder can cause what appears to be a huge memory leak, causing everything to in the game to run at roughly 1 frame per 2 seconds until leading to system failure, restart required (this continues to affect the system even after shutting down the game through task manager).
-Selecting view ship, then select fleet, then view ship again causes the ship to load black for a few seconds but also freezes the image, and paints said image of a black ship across the screen when rotating. This is similar to the old windows issue, where an application window could be moved around the screen filling it with copies of said window.

-Sometimes ship viewer is off center by quite a lot, reducing visibility of certain parts of a ship, loading in another ship resets this.
-When changing ship, camera resets, quite annoying when your trying to compare ships and the reset angle is on the shadow side and you cant see anything.

-And general instability issues, the framerate can suddenly drop and audio can stutter, usually leading to the system being frozen, in any part of the game, though it is usually very stable even on max settings, this will just happen randomly.
-when a mission begins or ends, there's always some visual or audio cut out or framerate drop.

I'm not sure if anyone else has experienced this issue as well but whenever I play Orks Tyranids, Necron or any of the Eldar/Dark Eldar fleets It will sometimes bug my speed boost ability. Basically I''ll use it and it will be set on cool-down but after the cool-down time period it will grey out the ability thus preventing me from using it for the rest of the match. This is a terrible bug that makes those particular fleets down right unplayable...

Having a few problems with the game so far.

First I've gotten a number of fatal error messages in multi-player games. It's happened about 4 times now (in maybe 30-40 games) It full on boots me out of the game and just says "fatal error". I suspect others are having the same issue as I've had games just end in victory at times that make no sense.

Several lesser issues:

The campaign movement map won't scroll using the mouse. You have to use the arrow keys to move the map (not sure if it's by design, but it's non-intuitive)

When I receive a new portrait as a multi-player reward, the faction is correct, but the picture shown never corresponds to the one I actually get (I've observed this for Orks, never checked if it's consistent through the other races).

When I select a unit, I can't give them orders more than a relatively short distance down the map. I can get around this by using way-points, but it's still sort of annoying.

Sometimes when the game goes to a loading screen, it first displays a random image from my previous game (usually just dead space or a deployment area) Pretty sure it's a graphical glitch.

The "reload" stance has no effect on lances or macro weapons for imperial navy, and possibly other factions.

After reading on youtube that reload was bugged, I tested it.

I just tested this in a skirmish this morning, the 21 of January. I loaded up 2 tyrants and 2 gothics, set one of each on reload, then set them all to hold fire, then drove up to an ork fleet, and turned hold fire off.

The volleys of all weapons, including plasma macros, regular macros, and lances, were perfectly synched up over multiple firing cycles, for both the ship that was in reload stance and the ship that was not. Reload stance does not work.

Had a bit on an issue with reloading a save, I wanted to go back two turns to fix a problem that I had put myself into. The problem is that when trying to load the old save the game would begin loading and put me in the loading screen but then the game would freeze, I tried waiting it out but after an hour I gave up.

Neither of the Necron hull healing abilities (Scarab Swarm or the base ability) are working for me. Was playing campaign, didn't have it work in any battle.

0_1548196942487_20190123093431_1.jpg
0_1548196964651_20190123093456_1.jpg

Started this battle with some damage to the left Shroud from a previous battle. Activated both scarab swarm and the hull heal ability. Hull value did not increase. It also doesn't seem to work for me on damage sustained during a battle.

EDIT: The healing worked fine in skirmish games, so it just seems to be campaign related.

last edited by tin_snips

Game shows not connected on the top right corner, Impossible to play Multiplayer.
This is an issue that has been in first game too.
I've posted a thread on this forum stating what have I done so far. Please assist, because I've already submitted steam refund.

After the beginning level for the Imperium campaign, I can't seem to click anywhere on the map. Belisar can't be selected. I selected it through the dropdown on the left. After that, I couldn't select Spire's fleet so...

@redkoi I have been having the same issue. It highlights Belisar when I mouse over it, and it highlights Spire's fleet after I select Belisar in the drop-down menu but it does not let me select them. As far as I can see every other part of the UI is working fine (that we have access to right after we get to the sector map for the first time). I wish we could use the fleet drop down menu to finish the objectives, but that appears to be greyed out until we pass a certain point.

While playing co-op the invited player has no ui, no skills, cannot see reinforcemnets, but has movement. This is standard, non beta. The bug happens right at start of battle, invited played also does not have any ability to orginize fleet prior to battle start, during the setup time.