Still broken on Xbox One X in 2019!!!

First things first: The Surge is a great game - I liked it so much that I, after finishing it on my ps4 pro 6 months ago, recently bought the Augmented Edtion for my new Xbox One X. Not only to play all the DLC but to experience the game in the best looking way on consoles. Well that was wishfull thinking because as soon as I switched to Quality mode it's GAME OVER! BROKEN! NOT PLAYABLE anymore! (Settings have been changed - Game Needs a restart!!) There is no way in hell I can Change back to Performance mode (except by deleting the savefile) - besides, I don't wanna play with more fps - I want the Quality stuff! But whats really shocking and disapointing about that issue: after experiencing the "qualitybug" I went to the Internet for help just to discover that this Problem is now known since 2017!!!!! and still hasn't been solved yet! wtf?????!!!!! I really tried everything that has been suggested here in this Forum - even stuff that hasn't been suggested - redownloading/reinstalling, Resolution Change, Profile Change, sign out/in - whatever. Nothing worked! I mean I am really happy about an upcoming Sequel to a really great game, but I would be more happy to play the original game in Quality mode (which btw was the only reason to rebuy the game). If I would have known about this issue before purchase I would have just bought the DLC for the PS4...
So... how about one more Patch for the X, hm?

Best regards

Wow... great customer support...

I personally think the xbox version was left to rot as there's still day one glitches in the game.

Lol nice support, anyway I encountered that just few days ago but I fixed it myself, when you open game that you changed it to quaility mode, and after the game restarted, if you see restart message appear even you already did, just restart xbox, not turn off and on, that just put it to standby, just actual restart xbox, full off and on then sign in and play, it works for me. Just today, I changed back to performance and still works fine.

I'm still dealing with console crashes in the nucleus after using the exo lifts (which has happened to me three times so far and I haven't even finished the area yet) that apparently have been present since the game's launch but still haven't been fixed.

I just upgraded a weapon with a nano core or something like that in the nucleus level, got the achievement and then boom. Freeze and crash/ shutdown of the console. Are you ever going to fix this game?

Restarted the game, load the save, used a pile of tech scrap and again, boom, freeze and crash shutdown my X1X. I even managed to close The Surge, but still, console shutdown

last edited by Cyphronite