Fatal Error on Start - Patch 3

Was playing perfectly happily last night. Patch 3 downloaded and installed this morning.

Now trying to start the game I get a fatal error.
0_1553240713273_BFGA2 Error 1.PNG
When I run the exe as admin directly I get this:
0_1553240892329_BFGA2 Error 2.PNG

Literally nothing has changed on the PC as far as drivers, software or config since yesterday.

Have verified integrity of files, to no effect.

Any ideas?

Hi @Ashantai
Thanks for reporting this and including the logs. Are you by any chance using multiple screens? If so, please see if this fixes it:

  1. Go to the properties of BFG2 on Steam
  2. In the general tab, Set Launch option.
  3. Type in "-monitor=0"
  4. Launch the game again.
  5. Please let us know what happens! 🙂

My issue may also be a result of using two screens.

I’ll try and upload my reports tonight

Having the same issue here and the monitor launch option did not fix it.

(I had posted my own thread before this went up but here's my crash log again just in case: 0_1553280554055_Armada2_CrashFiles_2019-03-21.7z )

@jellyfoosh said in Fatal Error on Start - Patch 3:

Hi @Ashantai
Thanks for reporting this and including the logs. Are you by any chance using multiple screens? If so, please see if this fixes it:

  1. Go to the properties of BFG2 on Steam
  2. In the general tab, Set Launch option.
  3. Type in "-monitor=0"
  4. Launch the game again.
  5. Please let us know what happens! 🙂

Hi there, thanks for the reply!

I do use multiple monitors. I tried that launch option and running on a single screen (disconnected monitor from laptop) but no joy.

Logs for new crash attached.0_1553281473727_BFGA2 Crash2.zip

Hopefully that gives some insight into what's happening!

Edit: Additional troubleshooting undertaken:

  • Disabled Firewall and anti-virus.
  • Updated graphics drivers to latest level.
  • Uninstalled and reinstalled game, removing all files from install folder and users directory.
last edited by Ashantai

Hi @ashantai
Thanks for the information. Can you please try to do the same procedure as before, but this time type in
"-WinX=0 -WinY=0" to the launch option?

@jellyfoosh said in Fatal Error on Start - Patch 3:

"-WinX=0 -WinY=0"

"-monitor=0" "-WinX=0 -WinY=0" in launch options worked!

Thank you! 🙂