Remapping "Sprint" not working

I'm using the Arrow keys for movement and I need to have sprint mapped on Rshift but even when i remap it to that key the sprint still only works with Lshift.

Is anyone else having this problem??

I tried using Autohotkey (RShift::LShift) and it still doesn't work.

Hey @Rompy,

Thanks for bringing this to our attention. I'll pass it on to the team, so they can investigate!

hi, Same for me, remap sprint key not work.

Same for me also, when will this be getting fixed? , game is unplayable fir me being a lefty.

Also a problem for me, cant reassign another key to sprint, trying r.shift, but no luck. Also Vault/Climb is not working with space even though ios it set a default. Please patch it so I can play. Thanks. Im also a lefty.

@mobimob

Before it is patched you can try Autohotkey.
I tested it works, if you leave Left Shift as your Sprint key in Game.
You might need to run the Autohotkey script as Admin if you have UAC enabled.

@deadlock_ said in Fix this shift key issue! Game is unplayable!:

@kyle939

Games ported to PC often have these kind of issues. Although far from perfect solution, you could use Autohotkey to rebind Right Shift to send Left Shift in Windows.

  1. Download and install Autohotkey (Current Version) https://www.autohotkey.com/
  2. Create a file shift.ahk
  3. Paste very basic script to that file. It will make Right Shift to act like Left Shift while script is running in background.
#SingleInstance force
#MaxThreadsBuffer on

RShift::LShift 

  1. Save file and run it.
  2. Change your Sprint, Run in game back to Left Shift.
  3. After finishing gaming close the script, it will create a small green icon in System Tray (near system clock) with 'H' letter.
    Just right click on it and chose exit.

Out of curiosity, what keys do you use to switch weapon?

I have the same problem. I don't wish to use AutoHotKey as it is a 3rd party program and shouldn't be necessary to change keys in game.