[Solved] Unable to join online games with players with same Public IP (probably) [PC]


Myself and 2 friends log into the game from our own respective computers within the same house (same network, google fiber).
We are able to join a lobby together and all functionality is fine.
Upon game start, 1 computer connects to the loading page and eventually enters the game. Meanwhile, the other machines sit on a black screen with only some white text at the bottom of the screen (text included below) instead of a loading screen. Eventually, a timeout is reached and the 2 machines that were on a black screen will return to the lobby screen where the count down timer (until game start) resets to 60 seconds and starts ticking down, causing an infinite loop.

Text as mentioned earlier:

2019.04.17 20:04:01  KSIVA: 5dd88  GV: 0.1.DEV.4586225/4586225  Env:prod-Master-https  Baine Reynolds  IP: ipv4://  ServerKSIVA: ---  type: DS  MM state: IN_MATCH  ExSID: fe4dd483-6174-11e9-b49e-

The log then trails off.

I should note that the IP and port are the same for both machines failing to connect. (of which the IP is not the public IP of our house)

Additional comments:

Changing who is the host does not change behavior.
Connecting to independent games works, joining the same game does not.


Set a static outbound NAT rule and everything started working for me.

last edited by BaineReynolds

I can confirm that using two different PC's in the same household can join the same game from experience, Are you able to try with a different router to try and isolate the problem or perhaps disable any anti-virus? Are you using a VPN by chance?


I use a pfsense (https://www.pfsense.org/) router which requires the use of a VLAN (as described here) . I do not use a VPN and I use DHCP for the IPs to the other machines. I've also been running this setup for over two years with no other games affected.

pfsense router

2.4.4-RELEASE-p1(amd64) (2.4.4_2 is out so I'll give an update a try)

PC-1: (my desktop is static, the other 2 are DHCP [range 0.110-0.250])

No two machines can connect to the same game.

Additional information

Only Malwarebytes is used, even disabled windows firewall entirely. Also tried temporarily disabling malwarebytes but no success.
All 3 machines are running windows 10 (should al be fairly up to date).

If there are logs that can be enabled, I'd be happy to do so. Sadly when I go to the game log directory (%AppData%\Local\Saber\WWZ\client\logs) all the logs are 0 KB (empty) which kind of defeats the purpose of having them in the first place, and doesn't really help much... If anyone could point me in the right direction, I'd be happy to do the heavy lifting. If others are not experiencing this issue then it definitely sounds like an issue on my end, I just don't know where to begin to look since everything else works so far.

last edited by BaineReynolds

Maybe try having your other two pc's use a free vpn service just to try and circumvent the game thinking all 3 clients are coming from the same IP? Just a thought XD

@rehzix84 it's certainly worth a try. I'll give an update here if I have any luck later.

@bainereynolds Awesome man, please do. I'm intrigued lol

@rehzix84 Well, I tested having 1 client run a VPN and the other client without a VPN and they connected. There is definitely a network level issue at play, now I just have to figure out what it actually is. For now, I have a bandaid but I'd rather not have my speed suffer through a VPN long term if possible.

That's awesome, at least now you know the problem. And you have a workaround to play while you figure it out!

Just wanted to give an update here. I managed to track down a solution of setting a Static Outbound Port mapping

Hi guys, ill posted the same damn problem days ago with no response.


Only the VPN worked for us to play together. after the Hotfix Update we tryed it only 1 time to join together. at this try it worked without a vpn.


EDIT: Looks llike it only worked for one time... same problem is back.

last edited by R0bsn

I'm having this problem to. Will this be fixed through updates? Cause I really dont want to download another program.