Bolt Action Bolting / Shotgun Pumping still bugged from 1.2(?)

At one point, I could reliably pump my shotgun and bolt my mosin faster by clicking at the right time and it became muscle memory that has helped me when I needed it most. After the last (not 1.3) update however it broke and I believe I reported it. The thing that broke is that the animation sometimes doesnt play. Now for me, when im firing a lot of shots with my mosin at a very fast rate, I sort of rely on the bolt animation not playing as a "okay reload right now" but when the animation of bolting doesnt play, now im hitting reload when I dont have to and wasting time, the same thing with the shotgun.

Id love to see this fixed, download any autoclicker and you can see the bug yourself.

Bump, because it didnt get fixed last patch either.

@Ziggylata I'm not sure if this is broken or not, but something seems off with the M24 especially. The Mosin seems to work fine.

@MarksmanMax said in Bolt Action Bolting / Shotgun Pumping still bugged from 1.2(?):

@Ziggylata I'm not sure if this is broken or not, but something seems off with the M24 especially. The Mosin seems to work fine.

Its a consistant problem for me, I practiced fast-bolting with the mosin specifically so I can pump out shots in a hurry but now its actually backfiring.

@Ziggylata Yeah, it seems to work fine for me. I thought the M24 should've been bolting faster, but I'm too used to the Greased Bolt, I guess.

Hey @Ziggylata,

Thanks for pointing this out. Do you happen to have a clip regarding this? I'll pass it on to the team, so they can investigate.

@chaton said in Bolt Action Bolting / Shotgun Pumping still bugged from 1.2(?):

Hey @Ziggylata,

Thanks for pointing this out. Do you happen to have a clip regarding this? I'll pass it on to the team, so they can investigate.

https://youtu.be/wsKNEGfnqXw
It was going to just be a bug report but I had too much fun making it.

Hey @Ziggylata,

Thanks for the video showcasing this issue. I have to say that I LOVE the music. Will pass it on to the team.

@chaton said in Bolt Action Bolting / Shotgun Pumping still bugged from 1.2(?):

Hey @Ziggylata,

Thanks for the video showcasing this issue. I have to say that I LOVE the music. Will pass it on to the team.

Just to clarify, this only happens when I try to bolt my weapon faster by pressing the mouse button at a very specific time. Sort of how you can slam fire by mashing the mouse button, but I do it without actually mashing so I dont shoot the second shot.

Thanks for the further details! I'll let them know!

@chaton said in Bolt Action Bolting / Shotgun Pumping still bugged from 1.2(?):

Thanks for the further details! I'll let them know!

I also decided to really showcase the difference it makes. I synced up shots from an unmodified mosin, a grease bolt mosin both non-slammed and slam-fired.

If you cant tell at the end, slow it down to 0.25 speed to really easily see it.

Youtube Video

last edited by Ziggylata

Thanks for the second video. Yes, it clearly showcases the issue!