Can't fire when crouching

The issue is, when I press Ctrl to crouch and press LMB before crouch animation has finished - the fire isn't starting!
I should release LMB and press it again to fire, but I often be already killed.
So LMB works only if it pressed after crouch animation finished.
Could you fix this please? It shouldn't be hard i think.

Hey @Sulfur,

Thanks for bringing this to our attention. Did this happen on a specific map or every map, please?
I'll pass it on to the team, so they can look into it.

This post is deleted!

@chaton Thanks!
I made video about it.
Youtube Video

I tested it on Refinery, Crossing and Hideout, and looks like the bug is on every map.
Even worse, I have this issue in Insurgence 2014 too!😁 Dont know, if this info will be helpful.

last edited by Sulfur

@Sulfur Thanks for the video! I'll pass it on to the QA team.

So, what you were doing was press Ctrl -> RMB -> LMB right?

I thought so, but looks like it happens even without RMB.
Just Ctrl -> LMB.

@Sulfur It may have something to do with your external keybindings, or maybe just your in-game keybindings. If you have a programable mouse - as in you can assign different buttons different commands - you may have, for a different game, been using a different button layout/button overlays for different scenarios. Also check you in-game keybinds.

This never happens for me. Try resetting your keybinds to defualt, but before you do, maybe write your custom ones down so that you can reassign them without having to deal with forgetting what they were.

last edited by CatNipples

I've got to agree with @CatNipples; not able to reproduce this myself. What keyboard and mouse are you using, @Sulfur?

@CatNipples @JoeK5142 thanks for trying to help.
I have simple Genius KB-110X USB keyboard and A4Tech X-710BK USB mouse.
I have no key binding programs, no special drivers and I not even rebind keys in game.

Is this a desktop or a laptop? Windows 10?

Do you have this problem in other games? Does it happen if you use a different key for crouch?

Sorry for not answering for long.
I tested another key (set Shift for crouch) and it was fine with it - the issue is gone.
So it's problem with my keyboard I guess.
I will try to find another one and will write here then.
@JoeK5142 thank you very much for support!🙂

@Sulfur no problem! What a strange issue... It could still be software-related (some software likes to bind global hotkeys, though ctrl+click would be rather overzealous for such software). I hope a new keyboard works out for you; definitely let us know.

Ok, now I know what the problem cause.
I didn't turned off little program which hooked keyboard to help with input language switching.
Now, when I turned it off the problem is gone.
I feel so stupid right now, sorry for not watched it properly.
@chaton say devs that issue is gone please, so not waste their time.
Thank you all!

Hello @Sulfur,

No worries. We're glad that this issue has gone!