Cannot apply a resolution higher than 1920x1080.

When I am in fullscreen and try to apply a resolution above 1920x1080, nothing happens. I can apply a resolution of 1920x1080 or lower but not higher.
I own a 4k TV. I have tried various things but one thing that works is to turn on windowed mode, this will make the game's resolution be set to the resolution of my windows desktop, which is 4k. But I actualy want to run the game at 1440p because this game doesn't run the best to begin with so I wan't to get better frame rates than 4k gives me.
So if I wanted to do that I'd have to turn down the resolution on windows to 1440p, then set insurgency to windowed mode and THEN the resolution would be correct. But I'd still be in windowed mode and not fullscreen.

I have mentioned this to a dev on the discord and this was months ago, various patches have come and gone so I'm assuming nobody knew about this or for some reason was overlooked.

It seems like a really basic thing, like, I want to run the game at a higher resolution... Pls fix.

I tried running this game on a 2160p TV and it worked for me.

Hey @Aeonimal,

Thanks for posting this issue here. I'll pass it on to the team again.