Can not go fullscreen

Recently i changed from fullscreen to borderless with no problems, now i tried to change from borderless to fullscreen and no matter what i do it just won't work, it is always borderless even if saying it is fullscreen in the settings, now i get frame drops like hell.

I tried:

1- Changing "LastConfirmedFullscreenMode=0", "PreferredFullscreenMode=0" to 1 in GameUserSettings.ini;

2- Set "-fullscreen" in Steam launch options;

3- Running the game as administrator and rechanging to fullscreen in game settings;

Yesterday when i did option 1 it seems to have worked but today it just won't. The game performance for me is 95% of the time great but now the frame drops makes it pretty bad as i'm getting 40fps when smokes are dropped or too much explosions are happening.

What can i do?

Specs:

Windows 10 x64 1903
I7-6700K
MSI 1080
32GB Ram

last edited by PushOrGetOut

Hey @PushOrGetOut,

Thanks for pointing this out. Can you upload your DxDiag here, please?

@chaton said in Can not go fullscreen:

Hey @PushOrGetOut,

Thanks for pointing this out. Can you upload your DxDiag here, please?

Sorry for the late reply, here's the DxDiag.txt.

last edited by PushOrGetOut