Hey, having a keybind problem here. It doesn't save.

Windows 10 x64
Intel i7-8700K

Keyboard: Ducky Zero DK2108
Mouse: SteelSeries Rival 300 (backup mouse)

Tried the following:

-Deleting the config files in %localappdata%.
-Unchecking read-only for Insurgency folder in %localappdata%.
-Making sure every user has full control over the Insurgency folder in %localappdata% and for the main game folder.
-Running game as administrator.
-Resetting the keybinds in the menu.
-Turning off Steam Cloud for both the normal Insurgency game and the CTE.
-Tried rebooting my PC.
-Tried Insurgency CTE. Doesn't behave differently.
-Running Steam and Insurgency without administrator rights.

Some important notes:

  1. "Apply Changes" button doesn't work properly for a lot of keybinds. Simply nothing changes. I checked this in Notepad++.
  2. I don't have any anti virus. Just noone, don't have it.
  3. I had the same issue during the free weekend a month back or so but I figured I would buy it because it would probably be easy to solve. It's usually just a simple Windows permission issue...
  4. Everything else saves. But not the keybinds.
  5. There are some keybinds that do change. Some always revert back to their defaults. It's either playing default, or not playing at all.
  6. Most of the .ini files in %localappdata%\Insurgency\Saved\Config\WindowsClient are completely empty. No idea if that's intended, I assume not.
  7. Windows update has no updates available, I got the latest GPU driver (436.30), latest Visual C++ Runtimes, latest drivers from my motherboards website except for the BIOS (see under this)

I just discovered a BIOS update was released on 2019/08/27. So I will install that at least. Highly doubt that will solve anything. But it's weird stuff so I'm hopeful(ish). EDIT: Didn't make a difference.

Video: https://www.youtube.com/watch?v=O8oLvcRuCOE

Note: When I first started playing there were a lot more keybinds that didn't work or acted weird. E, S, D, F was mostly E, ,D, D or something. They usually reverted back even before I went ingame.

Sorry for crappy quality. I recorded in 1080p and I don't know nor care how to make it look better. Recorded it with OBS in 1080 with a good bitrate, so I don't know what's up

Help ._.

EDIT: So I "solved" it. Or more like I found a stupid workaround. I went into the tutorial and into the Bind menu. Changed 1 keybind, applied the changes and went back into the game. After that back to the bind menu to set another custom keybind.

This game's keybind system is so broken. So I went and played the tutorial and for some magical reason (Insurgency's buggy ass keybind system magic) the tutorial stated that the keybind for crouching is "V" and "(". I of course didn't bind it to "(". And guess what..? Sprinting is also bind to "(". And also "Shift" for obvious reasons. This is definitely a game issue.

I find it appalling that this issue is still present 7 months or so after it's release. Bravo.

Last edit: So, removed the 5-6 "(" keybindings by editing the .ini and solved my weird sluggishness lag problem with setting the VRAM to 9216 for the TextureStreaming entries. I found a fix for the derpy antialiasing as well. So, all's good now, tomorrow I can finally play (hopefully).

last edited by Lifell