Trouble in Eden Glitched

Im having trouble with the quest Trouble in Eden under the Origins of Thélème. I have talked to everyone but had to skip the intuition speeches since i didnt have it high enough. I talked to all the missionaries by the shack where the tablets were stolen. Ive talked to the mal of the villiage it was built and father Lustinius twice at Eden. Checked off for objectives is the; 1. talk to Father Lustinius, 3. Question the theologions, and 4. Investigate the theft of the tablets of Saint Matheus. The one that isnt check off is 2. Learn the story of eden. I have tried going and talking to everyone again no one has anything to say and when i track it nothing pops up. I moved on past it thinking i would have to come back. I do not have the save for that instant so i cannot go back and retry the whole quest over. If anyone knows how to help or get oast this it would be much appreciated.

last edited by Fastrnu


There are 4 characters to talk to in that quest, did you do every single dialog, including "lore" dialogs from all of them ? (The chief of the natives in the hut east of the village, the lead priest at the center of the village, the missionary and the inquisitor that are in the west part of the village).

You might ave to try them all multiple times because talking to one might unlock new subject choices in the others.

If you are still blocked after that, could you please send us your save file ?
You should find your save files here C:\Users\xxxxx\Documents\GreedFall using your File Explorer. We recommend making a manual save (with this type of name: save_xx-xx-2019_09-53-26.fsav) and sending it instead of sending an autosave file.

Using a file sharing site like is fine, you can send the files to

Sorry you’re experiencing issues with the game

Best regards.

last edited by Focus_Victor


Has there been a fix for this issue, because I am having the exact same one. I have gone and talked to all of the listed people multiple times and they all just give me option to leave, except for the missionary who tells me she is to busy to talk and just automatically kicks me out of the conversation.


I'm having the same issue as mtimber13. Tried talking to everyone and nothing has triggered.

I as well am having the same issue, and because I didn't realize it was bugged at the time I have lost the ability to go back and redo the quest as my save files don't date back that far anymore so I am stuck with my reputation as "suspicious" for Theleme very late into the game. Please try and fix this sometime soon as they are the only faction I am on bad terms with because of this glitch 😞

I’m having the same problem. Really pissed off because this was a mission I was super excited for. Also on ps4 so I can’t send save data