My brief observations so far with the test server:
(Windows 10 platform, Fanatec Podium Wheel Base DD1, ClubSport Steering Wheel Universal Hub for Xbox (set to PC mode) ClubSport Pedals V3 inverted and ClubSport Shifter SQ)
Interface:
• Can’t use Podium wheel pre-set as the camera zooms in as soon as you move any axis (wheel or pedals) have to set custom from scratch

• All axis (pedals and wheel) interfere with menus and map. (have to rotate wheel to find a dead spot and be off all pedals before anything in any menu can be selected or the map can be manipulated, or it flickers around all over the place)
• Button set to open map doesn’t close the map (have to press esc)
• Button set to operate winch doesn’t operate winch (have to push F on keyboard) but it does initialise quick winch, but not operate it)
• Winch sometimes operates itself as soon as you attach it to something. Have to change to another vehicle and back to rectify
• Can’t set any camera functions to buttons / funky switch or it just spins round or zooms right in when you move any axis

Gameplay:

• Lost container still lost (is not on map outside warehouse where it should be in Black River) Can’t reset.
• Can’t reset tasks. (dropped a cement bag on Smithville lost bags task and it disappeared, can’t complete task or reset)
• Interaction on Coop sketchy, cannot load another player as the cargo falls through their truck and disappears
• When you retain all you vehicles in someone else’s Coop you loose the ability to deploy them or exit garage or enter map. Have to alt – F4 to get out.
Saying all that I LOVE this game! The improvements you made to the graphics and physics on the test server are great. And FFB! Excellent! Works a treat. Have it turned up to 1080° and ~10kN force. It’s quite a workout! 😰 😅