FYI: new update breaks/uninstalls mods.

i am sure a few of you have found out by now that his new valley DLC update breaks mods, as in it uninstalls them. so just to let people know when you download the update be prepared to spend a bit of time putting your modded files back the way you had them.

last edited by 8up local

Yup found that out the hard way just finished putting everything back in...All my maps were gone and the path for the media folder, tattoos gearbox, however, the 4gig and mudrunner plus still worked but I reinstalled them anyway.

@smaronenine STMR mod was still there for you? strange but yet lucky? mine is totally gone and i have to install it again.

@8up-local yeah man still worked very weird....like i said just my maps and paths were messed up.

ok after a bit of digging the new update has replaced my edited files as well (texture, media and meshes zips). so any zip files that you might have replaced will need to be re-edited again also.

last edited by 8up local

@smaronenine you get the STMR mod working? i have tried uninstalling/reinstalling it a couple times now, but can not get it to work.

@8up-local stmr mod? thats just the mudrunner plus thing right? yeah it was working but it was already still working for me all i did was re drop it in the directory and its still working.

You guys got any advise if the game wont start at all? Nothing modded other than a couple of workshop mod. Reinstalled a couple of times and deleted appdata but nothing. Pressing play in Steam and nothing, NOTHING. 😕

@smaronenine yeah the ST+ mod thing. mine is not working at all and not showing up in my game settings screen. i have uninstalled/reinstalled it a couple times now, but no go so far. still not working for me.

@bluebirde i have seen where some people have uninstalled and reinstalled just the workshop mods and are getting there game to work. not sure if this will work for you, but worth the try i figure.

funny how with this one update that so many people are have such different problems it seems.

last edited by 8up local

@8up-local I really don't know man and I don't wanna take mine out and try to reinstall it if it's working.

That moment when you know how the developers feel about mods that don't conform to how they want the game to be.

It was clearly intentional.

I get the mod not working. But to erase maps from the media folder is redicilous.

@articzap
Did you check the folder? Everything I had was still there and intact after the update including mod maps and trucks. All I did was put the lines back in my config.xml and voila!

well the save files, map files and the folders for the mod map i was on were still there, but the game did not register it when i restarted my game. so i reinstalled the map, but it still is not registering. i think this might be because i add my maps manually. i do not use the map install mod or jgsme or whatever it is called. so this could be the problem for me. i noticed the new DLC map is a zip folder in the game folder, which is something new for a stock map.

@SmarOneNine yeah don't take the chance. i am still trying to get my STMR mod working, maybe tonight after a break from this i can figure it out. right now i am about full of looking for and replacing files. i really need to set up a game folder so i can replace all my files one go. my mistake though, i know i was needing to do it and now i have a good excuse to. lol

@articzap nothing is intentional, this is actually quite normal for ST really. so to me it is no surprise that it also has happened with MR.

the excitement of the New DLC is really lost in the fact that, a lot of people are having to repair/replace their files... Rufus

found my problem with maps. it was on my end. i had the file path on the wrong line in my config. so far it has not been too bad really with the errors and the new DLC. however it does seem that the STMR mod (ST+) might need to be updated. i say might because it seems some people are not having any issues, but a lot are. i am wondering if the version of the STMR mod matters?

edit: it also seems some people are having problems getting their files working for building their vehicles and being able to access them. anyone else having this issue with project vehicles and maybe even their maps in the editor? please post if you are.

last edited by 8up local

@mexican_420

Same here. Just a simple rewrite of the config file and good to go. I would guess most players having issues must have installed maps/mods directly to the media.zip file instead of creating a new folder and pointing the config file to it.

ok so far this looks like the rundown.

  1. mod maps and shifter mod work, the game config just needs re-edited with the file paths added back to it. (add shifter mod to the end of the config as usual and the media path goes after the media zip path line in the config file)

  2. textures, media and meshes will need to be reinstalled to their respective zips, if you had edited any of the files. (skins/textures, sounds, edited files/coding)

  3. STMR mod is still undetermined although it looks like it could just be the version being used (this is not confirmed yet, but 1.6.6 versions seems to have broken while 1.6.7 version looks to be working). we need more feedback on this.

opinions or feedback?

last edited by 8up local

1.6.7 is not working for me, i don't know if a couple of trucks and a new map are a fair trade for this hassle?

my STMR mod is still working. i am using v1.6.7.

@smaronenine said in FYI: new update breaks/uninstalls mods.:

@8up-local stmr mod? thats just the mudrunner plus thing right? yeah it was working but it was already still working for me all i did was re drop it in the directory and its still working.

awesome that its working, but did you say you re dropped it in the directory? i just opened the mod up and ran it. i have never dropped it in the game directory. just trying to verify?

anyone having issues with getting modded MP to work?

MP doesn't seem to work with custom objects for me anymore. I got it to work with a custom map with no custom objects. I got custom maps and objects to work in single player. I tried packaging my map up like the zipped dlc and added a line to the config file. Tried adding my custom objects to the media.zip. Tried my original way with the unzipped media and with the edited config line. Tried JSGME. I've also tried Mod 1.6.5, 1.6.6, 1.6.7 none of those work for me anymore. Between each change I would verify files back to original. I'm totally confused why some people would be able to use their 1.6.7 (or any version) of mod and others can't. Must be missing something. Shot in the dark but I have all my game files on D:\ and I wondered if it made some changes to C:\ that the mod isn't seeing anymore. Good ol spintires doing what it does best! Hopefully someone smarter than me figures out wtf is going on.

i'm with you Gambler, i went thru everything my limited knowledge has , mirroring your attempts and still cannot get any thing to work like it did right before the DLC. CAN I JUST PREVENT THE DLC ACCESS TO MY GAME???? I'd rather keep on the way it was...

@rufus you can uncheck the box for the DLC in your game properties in steam. i have not done this yet though myself. just open the steam library and right click the game. select properites and go to the DLC tab.

Makes no sense at all that some people are having these kinds of issues and some are not like WTF right, Literally nothing is wrong with my game at the moment (knock on wood) I just finished a bunch of testing all my current tweak mods are working fine,
-Tattoo Shifter - had to Reinstall after update
-My Maps - Had to remake the Media Path and folder after update
-Mud Particle - Had to remove it again after update
-The 4gig Fix is working fine - did not have to reinstall after update but did anyway / drag and dropped
-The Mudrunner Plus or whatever its called is working perfectly - I did not have to reinstall after update but I did anyway / drag and dropped...I'm running the 1.6.6 version.

I just set up a MP session and launched it solo and that's working perfectly with my maps/ mods, I cant test MP with a friend yet because none of my friend's games are working correctly, I know none of this helps anyone whos experiencing problems i just dont understand how some have these problems and some are not because of a simple update....What happened to being excited for updates? I fear the next one.

last edited by SmarOneNine

@SmarOneNine
Carrying over from Oldtires, ALWAYS fear the updates...
"Vanilla game's running great, sorry about your mods... Again..."
Remember when even small background updates would nerf every single mod map?

@smaronenine i hear ya in fear for the next one, but at the same time this game (spintires) has always broken things with major updates, so i was not surprised myself when things broke. just nice how fast the community acted this time around was beautiful imo. true not everthing is fixed and working, but still a fast recovery so far imo. i am proud at us for not just getting most things fixed quickly, but how little people complaind this time around. i say this without really checking how bad it might be in the steam discussions though lol.

well unless we the community can figure out the rest of the broken stuff i guess we will just have to wait for what is still broken? to be updated and fixed. i only question the broken part since not everyone is having problems.

last edited by 8up local

@8up-local Stay very far away from the steam discussions just a warning lol, there's a lot of crying going on in there omg.

@8up-local - I unselected the update in Steam and tried a few times. The new level doesn't show up but it didn't work for me. I did try entering the lobby and swapping the files to a modded map similar to the JSGME method. No luck there either. Totally baffled why some people were able to keep their mudrunner mod. I have suspect something to do with the d3d9.dll file I had a friend that was having issues installing the mod pre-update took us a while to figure out and we narrowed it down to his direct X file being damaged. I'm wondering if something similar has happened to some of us. I'll try and track down what he did and report back.

Could I get people that have a working mod to report if they have any additional d3d9.dll files? There seems to be a trend happening. For example a d3d9.dll 43 or 44.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.