Public Beta - The Valley Performance Issues
Community Manager

0_1518710800590_2.jpg

Hello all,

We'd like to announce a public beta for testing a fix for some performance issues that have been noticed since the release of Spintires: MudRunner's free DLC, The Valley. This beta will last until Monday.

In this public beta, you will be able to play multiplayer with players that aren't in the beta.

This latest beta is available as a public branch, and can be accessed by doing the following:

1. Right Click Spintires: MudRunner in your Steam Library
2. Click Properties, and then Beta
3. Select public_beta from the dropdown menu

Once done, you will be entered into the public performance beta. This should fix any performance issues you've noticed since the release of The Valley.

If you continue to encounter issues in this beta, please provide your logs (which can be found here: C:\Users\Name\AppData\Roaming\SpinTires MudRunner, and uploaded to WeTransfer and are generated by holding SHIFT while launching the game) and your list of mods.

if the beta version is worse for you than the current version, please revert to the base game, and give us your logs and list of mods, as detailed above.

Please let us know in the comments below if this does fix those issues, your feedback here would be greatly appreciated!

last edited by Iyagovos

Hi,

Will be any performance beta for console players?
I've having performance issues playing in Xbox One X since the DLC update.

Any beta testing for a flatbed/transport version of the e class garage trailer? 😂

last edited by komradred

but what were the problems? Catalyst in multiplayer - everything is fine, the only thing - if you turn off the game in multiplayer mode - then there was a breakdown of the Internet, and everything was fine, like it was link text

ok so you want us to beta test your dlc .. i take it this was not tested then ?

I wander if the FFB will be fixed in this beta, Currently, since the release of the DLC, in order to get my FFB working again I have to go into controls and press each pedal one by one and then rotate the wheel before the FFB enables again. This happens each time I load up the game so do not believe it is an issue on my end.

@bogelma said in Public Beta - The Valley Performance Issues:

but what were the problems? Catalyst in multiplayer - everything is fine, the only thing - if you turn off the game in multiplayer mode - then there was a breakdown of the Internet, and everything was fine, like it was link text

In my case, in console version I have bad framerate and high ping in multiplayer games.

on ps4 everything is running 100%👍👌😉

@fabio-brasil said in Public Beta - The Valley Performance Issues:

on ps4 everything is running 100%👍👌😉

I think is something about Xbox one X 4k patch, that is not working correctly.

PC only, guys. Unless you have Steam on tour PS4/Xbone...

TL;DR: DO NOT TRY THE BETA UNTIL YOU HAVE READ WHAT I HAVE TO SAY HERE. I AIM TO SAVE YOU SOME TIME AND HASSLE BY NOT NEEDING TO BOTHER WITH IT....HOPEFULLY

Where to begin? The beginning I guess. Got the Valley DLC update on the 13th. Totally broke my game. Unplayable .5 FPS nightmare. Did some looking around to see what other folks were doing about it. Heard someone say reinstalling the game fixed it. Tried that. Didn't fix it. It appeared to work briefly. When I tried running them game immediately after Steam said it was ready to play. This was as soon as the game was installed, but the workshop mods were still being installed. I'd saved the workshop contents folder before uninstalling the game. In hopes I could avoid the waiting for 11GB of mods to download by using that as a backup. Didn't work, game said no mods there after putting it back where it goes. I didn't want to play without workshop mods, so I closed the game and waited for them to finish downloading. Got pissed off at that point and pitched a fit that my plan didn't work and I ended up having to wait for mods to download anyway. Made some angry posts, here and over on Steam.

I decided I couldn't wait to play until all the mods downloaded, so with about 50% still remaining I started the game up. Instantly realized that the game was no longer working. Same as before reinstall. Got back on here and read a post saying to unsubscribe from all mods after reinstall and that would fix it. I then made a post about having figured out that it had something to do with mods. But I'd made up my mind I was not going to be unsubscribing from mods, unless it was going to be the last thing I did. I decided I was going to try and find a better way. Around about that time the workshop mods were 95% finished downloading. I started the game up at that point and...BAM...it was working perfectly again. So much for the unsubscribing from mods idea. SO GLAD I DIDN'T DO THAT! No reason to. Game's working perfectly without it. Took the time then to go back and edit my post to reflect that.

2.5 days transpire. During which the game is working flawlessly. The today I start it up and it's broke again. Decided to try the beta. And THE BETA FIXED IT. But, and this is A BIG BUT, it broke SpintiresMod v1.6.8 in the process. NOT GOOD!!! I need that!!!

So I threw up another pissed off post here. To which I got this reply...
@shadowsincere said in Microstuttering after update (Fixed - Workarounds):

@mudhappy Same shit happened to me too, didn't try the beta though.
Once again go to single player > manage mods and delete all no name (blank) mods.

Fixed it for me but yea the big question WTF happened that suddenly a bunch of mods disappear....

Hmmm I thought. I'll bet he's onto something there. I wonder what it is? I noticed when updating SpintiresMod from 1.6.7 to 1.6.8 that he'd changed the way his program was listing the names(or lack thereof rather) of workshop mods.

Used to look like this with 1.6.7...
0_1518831919109_1.6.7.PNG

Looks like this now with 1.6.8...
0_1518831962169_1.6.8.PNG

So what's up with that? Is there a problem with the names of workshop mods? I believe I have all the evidence to prove once and for all that YES...THERE LIKELY IS!!! And it's a "problem" that Focus has actually created, and needs to rectify ASAP!!! Without a beta that breaks things as much as it fixes them. JUST FIX WHAT NEEDS FIXED...AND NOTHING MORE!!! You know exactly what the problem is. It shouldn't be that difficult to undo it without a beta that breaks things that don't need broke. Hell...you don't even need a beta PERIOD!!! You just need to tell us what's going on, and the simple way to fix it. Which is actually A WHOLE LOT EASIER AND DOESN'T BREAK ANYTHING!!! But no. Just pretend like you don't know what's going on and make me do all the work here. Whatever.

So here's the deal with it. Just do like he says and...

go to single player > manage mods and delete all no name (blank) mods.

PROBLEM SOLVED!

"But I don't want to delete any mods" you say. Yeah...me neither. But trust me on this...YOU WON'T REALLY BE DELETING ANYTHING. Aside from the damage done by the Valley DLC update. Here's what/how/why...

This list of mods here is corrupted by 10 invalid entries.
0_1518832896443_20180216155257_1.jpg
0_1518833001016_20180216155316_1.jpg
0_1518833013025_20180216155336_1.jpg
0_1518833025951_20180216155401_1.jpg

Wherein lies THE ENTIRE PROBLEM!!! Just delete those entries and...BAM...you're done! You don't even need to restart the game. Like magic it will start working perfectly as soon as you delete ALL(could be more or less than 10 for you) the empty spaces and click OK. If you're confused by how to do that, it's super easy. Left click on the empty spaces in the list(individually/one at a time) and, after highlighting them, left click on <<. Do that for each instance. Then left click on OK. If it doesn't immediately fix your game, go back through the list again. Because you missed one(or two or however many).

How can I prove it's not actually deleting any mods? I'm sure I can. But I have enough valid reason to not bother counting each and every mod before and after to be 100% sure. So I haven't. But hear me out and you'll see why I think what I do.

The problem seems to be with just that manage mods list itself. I thought(and still think) it might also have something to do with these strangely named mods that I'd found in the billboards before deleting the empty spaces in the manage mods list(or why would the beta correct that? more on that later). I checked the billboards again after to see if they were being deleted or not. And they were NOT DELETED. Nor were any other mods that I could tell. And when I searched for mods afterwards, in manage mods, "No available mods found!". Coincidence? I think not. Now for the pics of before and after.

The 12 oddly named mods I found prior to deleting the empty spaces in the list(without the beta installed, more on that later).
0_1518834193989_20180216150656_1.jpg
0_1518834247986_20180216145831_1.jpg
0_1518834267789_20180216145918_1.jpg
0_1518834280644_20180216145947_1.jpg
0_1518834308468_20180216150034_1.jpg
0_1518834319162_20180216150126_1.jpg

The same 12 oddly named mods after deleting the empty spaces in the manage mods list. Only in different places this time.
0_1518834455239_20180216165236_1.jpg
0_1518834465127_20180216165407_1.jpg
0_1518834478787_20180216165436_1.jpg
0_1518834489411_20180216165457_1.jpg
0_1518834503026_20180216165523_1.jpg
0_1518834529633_20180216165539_1.jpg
0_1518834546003_20180216165557_1.jpg
0_1518834574891_20180216165645_1.jpg

Now what does the beta have to do with all this? Good question. As stated, the beta works. I've tried it. I don't know exactly how. But I do know what it does and what it doesn't do in regards to the manage mods list and the 12 oddly named mods in the billboards. Which I believe is of crucial importance.

So...the beta...

  1. It doesn't fix the empty spaces in the manage mods list. It ignores them somehow.

  2. It does fix the names of the 12 oddly named mods in the billboards.

  3. Other than those 2 things I don't know exactly what all it does. Well...besides knowing it's not needed to solve the problem, and is therefore a waste of time, and that it breaks SpintiresMod.

Pics for #1 are above(no need to post them twice, same 10 empty spaces as before).

Pics for #2 are right here. All 12 mods with more normal looking names.
0_1518835134767_20180216153551_1.jpg
0_1518835145819_20180216154742_1.jpg
0_1518835164543_20180216154812_1.jpg
0_1518835183517_20180216155005_1.jpg
0_1518835199276_20180216155108_1.jpg
0_1518835213454_20180216155139_1.jpg

Pics for #3? You'll just have to trust me that it's all true.

So what's really going on with all of this? I think it has something to do with the empty spaces in the manage mods list, 100% certain of that actually. But these strangely named mods that the beta fixes might be a part of it to. Something's going on with all that. Frankly though, I don't really know what, and I don't really care. Why 10 empty spaces and 12 strangely named mods? How's that add up? Again, don't know, don't care. All I care about really is that I get to play my game now with SpintiresMod v1.6.8 installed. And so far as I can tell I didn't I didn't lose ANY workshop mods in the process. And I didn't need to do anything but delete some empty spaces in the manage mods list to fix the stupid problem THE RIGHT WAY!!!

NO BETA REQUIRED!!!

CASE CLOSED

Sidenote: I tested all of the mods with the strange names with the beta and without. They all work just fine with and without the beta. So the problem IS OBVIOUSLY NOT with the mods themselves. So why delete, and/or unsubscribe to, any workshop mods? Too lazy to just delete some empty spaces in the manage mods list would be the only reason that I know of.

Of course I could be wrong about all of this. But I highly doubt it. Well see I guess...

last edited by MudHappy

I just wanna chime in to say that I didn't notice any problems after installing the DLC.

I have a 2008 Dell quad-core, 8 gig ram, and GeForce GTX 650 Ti Boost on Windows 7 Ultimate, if that matters.

Running the Beta version, the game is running fine with mod installed i missed the new menu under the default truck at first, plus you have (to double click?why) on the mod to make them available in the party,otherwise great dlc i like the map it really feels like a real exploitation mixed with arch environment weather who went through that map.
The litlle star are great indicator on people who are most likely to stick to the job and not leave after a few minutes.
At last the new truck are a great addition to the game and the fact you can chose your own is really a welcome addition.

The only litlle bug i have now is mostly when you open the truck menu in the lobby who close by itself each time someone is joining the lobby.
Log : https://we.tl/5myd5CSRZN

Also would be nice to have an in depth change log on each update to know what has changed. 🙂

last edited by Raphael

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.