Analog microphones don't work

Updates in bold

Reproduction steps:
-Verify mic works/configured correctly in Steam, Windows, and every other audio-input utilizing application.
-Once game is launched, open up Steam Overlay—>Friends List Settings—>Voice.
-Notice during a mic test with Push-to-Talk or Push-to-Mute enabled that not input is recognized (if "short sound on mic" is toggled, that sound will not play anymore either).
-Open Microphone test DOES work but the game has no open-mic option (also, the Push-to-Mute Toggle for Open Mic doesn't work either); you must use a Push-to-Talk keybind.
-Change Steam Chat Push-to-Talk/Mute keybind to match the same in Sandstorm or differently—neither makes a difference (Sandstorm will always use its keybind regardless, as is verifiable by the Team&Promixty or Proximity popups in the lower left corner in-game).
-Verify in game text-chat that in Sandstorm space, no one can hear you scream.
-Launch any other audio-input utilizing app (e.g. VoIP) and notice/verify they still receive mic input.

Yes I know there's an abundance of threads on the mics not working only in Sandstorm ever since Steam rolled out its new Steam Chat features (a whole year has gone by w/o a fix), but none mentioned this specific problem/observation.
Yes I've tried an abundance of troubleshooting:
-rebind keys
-change Steam Chat Input Device
-tweak Steam Chat's various voice settings (don't get on me about gain—every available location is maxed out)
-tweak Windows mic&speaker settings
-tweak audio card settings (yes the drivers are up to date)(Sound Blaster discreet and Realtek on-board audio cards)
-verify game integrity cache
-used different mics and/or headsets (mic&speaker TRS 3.5mm(separate TRSs and TRRS to Y-TRS))(Logitech & SteelSeries headsets) USB-only or adapter works
-reinstalled game

I'm on Win7 and notice its "Set up microphone" for Speech Recognition is visually nor audibly helpful and wonder how that configuration goes on Win10. I also notice that once the game is running and the Steam Push-to-Talk/Mute is disabled that the Overlay will not let me rebind to my secondary (Logitech) mouse keys—it will still take the primary mouse-keys as bindings—even though the game (and everything else) still recognizes all of my mouse's keys. I've also noticed that under some unknown but likely specific circumstances that the game stops recognizing certain keystrokes/bindings while in the Settings menu—namely the Esc key to exit the menu, and the F# keys to Apply and Reset settings; I have yet to isolate that issue whether its related or not.

I'll update the OP with more troubleshooting and reply as I try more things; next on the list is reinstalling the game...

last edited by toltecher

Isolated the mic issue to analog input; I used my old Logitech analog-Y to digital-USB adapter and was able to be heard by other players who confirmed they were all using USB headsets, which is a shame (at least in my case) because the digital conversion delivers poor audio quality and adds in arbitrary bass-boost that completely muffles and ruins the beautiful (and balanced) soundscape that the sound team developed. Renaming the title for more visibility to more relevant issue, will also make a post on Steam forums since that will provide more visibility to more players overall; will submit two separate bugs to NWI since the Steam Overlay problems are a separate issue from analog inputs not working (now that I found where to do that; for some reason it's not posted or pinned anywhere on Focus' forums—had to find it in the Steam forums).

@toltecher I use analog, with the sound blaster sound card. The only issues i ever had were with discord. I have always been able to use voice in game. Not sure if this is for Insurgency or sandstorm, but i play sandstorm.

@simmerdown which sound blaster card do you have and what operating system are you running? I have an older (9 yrs old) X-Fi Titanium HD but I didn't have this issue w/ Sandstorm before until sometime after Steam updated their chat system and all the mic bug threads started showing up for Sandstorm; I hadn't been playing for a long time so I didn't realize this was an old issue until recently.
Also what make/model headset are you using and have you ever played Sandstorm with it plugged into your onboard soundcard?

iPhone earphones mic don't work either, even though on Steam chat it does.
Any fix for that?