Weird Black Smoke Boxes

Hey everyone!

So I get the new update..... no issues. Until I roll some coal. Yes i do have spintires mod, and custom maps. I have tried disabling both, but i still get these mysterious black boxes.


I have also tried to lower my graphic settings to low... no luck. So it must be my game.

Pictures of black smoke boxes:

Any help?

Stab in the dark would suggest a wonky texture or alpha. Have you verified files via Steam?

Yes. I have tried to uninstall and reinstall the game, lower my graphics. Wonder why it does this.

So this has only been a thing for you since the DLC update? Same with stock and modded trucks? Is it only the diesel trucks with the black exhaust smoke, or does the same thing happen with the little scout trucks (light exhaust smoke)?

It happens when a truck

  1. a truck rolls coal
  2. any truck (small or big) goes in ANY water.

If there is a fix, describe it below. The black smoke boxes destroy the game.

@riskywisky said in Weird Black Smoke Boxes:

Yes. I have tried to uninstall and reinstall the game, lower my graphics. Wonder why it does this.

Not uninstall and reinstall, verify the files. This will put any game files back to stock, then test. Process of elimination more or less...

I have even verified my files. It still does this. Is there a fix?

Community Manager

To confirm, does this still happen with no mods installed?

If I didn't know any better (and I probably don't!), then that symptom looks exactly like what happens in Flight Simulator X when the PC is struggling to cache the textures and display them.. Yet FSX is more than 10 years old, 32-bit coding which can only run DX10 with a fixer... 🙄

Not to derail the thread, but it's actually a little bit depressing to realize that FSX is that old... lol
Still installed on my PC too!

WEll... it still does this even without any mods (even workshop ones) like I said above, I don’t have great specs.... my specs are the first link in the first post. Well, still been a week and a half.... no fix

Your specs destroy mine, but I I have no issues...
I do vaguely recall seeing it happen once or twice for me, but I think a simple restart of the game resolved it (which you've already tried several times so it would be a moot suggestion).
No graphical corruption in any other games, right?
No changes in any other software that might coincide with the issue starting?

last edited by Mexican_420

Everything happens in mud runners.... no other game does any weird stuff. I have disabled mud runners in my AMD control panel.... no luck. So my assumptions are that it is some rendering issue. If any of the devs are viewing this, please help. I have also tried using the public beta. No luck.

It has only started happening when the valley dlc came out ... then those smoke boxes reappeared. I do remember in older versions the smoke boxes would happen very rarely.q

@riskywisky after valley dlc my frames started dropping randomly when im rotating camera so there is some issues with that update.

Did notice that as well, but it put my resolution back up to 1080p when it was stocked at 720p.... all it did was reset all of my settings. But yes there are issues with this new valley update.

If you disable (unsubscribe?) The ValleyDLC via Steam and run the game WITHOUT the DLC installed, do you still get the boxes?

I think there was update to game aswell along with dlc as i noticed some changes to _cockpit effect on my mods.

Don know how to disable the valley dlc...

There was in fact a update alongside the valley update... I noticed new overlays... and new tree assets for maps.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.