Stuck connecting to New World Services and I've already synced the clock too

As of patch 1.7.1 I can't find any online game at all, official nor community. The game never connects to NWI services, and from what other people have had in the past, updating the system clock with internet time should apparently solve the issue...but it hasn't. My system clock is already up to date.

I've tried deleting all the ini files, no dice. I've tried reinstalling the entire game, no dice. I've even tried changing DNS servers (was on, went to, then just set it to obtain DNS server address automatically), still doesn't work.

Why did this have to happen only on the patch I've been waiting forever for, the one that brought back vehicles to coop? 😞 Wish I had that kind of luck with the lotto...

Having the exact same issue. I've already submitted a ticket to OWI, here's hoping they actually get to it, but it's been a few days.

Oh man last time I submitted a ticket they never responded lol, that was a few months ago. I'd imagine they get so many from irate and upset players as well as trolls so I wouldn't be surprised if they just gave up on it.

I'm just glad this doesn't appear to be an isolated issue. Really wanted to play with this patch.

edit: lol so it seems like the ticket I submitted to them a few months back is no longer there i.e. they deleted it lmao

last edited by edbods

I tried enabling port forwarding thinking maybe that might help it, even if the game was running fine prior to this patch without port forwarding enabled, and that got me nowhere.

Want to update this in case anyone else gets this problem: I completely reinstalled steam and it started working...not sure why this would fix it, but it means I no longer have the nice, efficient old steam library...