[Solved]Editors broken rebuild terrain function fix??

So this isn't a new issue I'm gonna bring up here, but one I've been working around. It's a rather annoying issue at that. This being the rebuild function of my map editor totally demolishing the terrain. (Simply adjusting distributions, or terrain is enough to destroy those edited blocks.) Rendering everything way below where it should, producing the good old floating objects. I've been working around this by saving, deleting the levels files and closing reopening and reloading the map forcing it to "create" terrain instead of "rebuild". I'm not sure the difference but the latter fixes terrain issues. If there is a fix to this plz share I've been battling this for a while.....☹

@Pavel can we possibly get a fix for this? And maybe the ability to multi select objects? Plz 😇

last edited by DrGoNzO1489

@DrGoNzO1489
I haven't been having any issues with the editor, but I also haven't made a map since before the latest update either...

May try backing up my stuff and reinstalling... I've verified numerous times....☹

I've not encountered this issue yet. That would be annoying tho!

Yes this is an annoying thing for me too. The only way I have found around it is too change the geometry in very small amounts at a time and then rebuilding the terrain. Takes much longer though

This happens to me too sometimes. So far all I've had to do to fix it is rebuild terrain again/one more time after it messes everything up. That's worked every time.

You've probably already done so, but in case you haven't there's the "turn off the Steam Overlay" trick that fixes floating objects. I'd already done it some time ago. Then I just checked a few seconds ago and, for reasons unknown, the box was somehow checked again. I unchecked it again. So maybe that will help with it. Though, in all honesty, I never had any floating objects appear with it turned on at the time I turned it off. I just happened to hear about it and turned it off as a preventative measure. I'm not sure how long it's been turned back on though. And this issue with the floating objects has only been happening to me fairly recently. So maybe there's a connection there. I assumed it was still turned off the whole time.

last edited by MudHappy

@sully-courage can't even do that simply applying a single brush stroke,A single click will break the terrain....

@drgonzo1489 I get those errors if the Steam overlay is on. If not maybe its close to the max memory and it's starting to freak out? Just a guess.

@gumbootgambler said in Editors broken rebuild terrain function fix??:

@drgonzo1489 I get those errors if the Steam overlay is on. If not maybe its close to the max memory and it's starting to freak out? Just a guess.

My overlay is on! How do I turn that crap off!?!

This happens to me once in awhile, I don't know a fix but if I have the effected area in view and "rebuild visible" it fixes it. 8 seconds to "rebuild visible" is better than 10-12 minutes on "rebuild terrain"

@drgonzo1489 oh shit yeah that fucks everything up - goto steam, settings in the top left, In Game, uncheck enable steam overlay. I swap mine back and forth because you need it for screenshots.

@gumbootgambler you are the man!

@drgonzo1489 It was in Nix's editor tutorial - the 4th video. Yeah that messed me up too.. Gave your map a go with Gabe last night. Pretty fun, whole new map basically!

@joridiculous well it was broke and now with the overlay off it works so problem solved I knew it was something stupid....

@joridiculous yea the easiest way to fix that is to grab the automatic? Mud brush, and set to 0. Then paint corrupted area to remove all mud and then re paint the mud in that area...

@joridiculous lol the editor needs some love I guess is the story here....😜

last edited by DrGoNzO1489

Haven't had these issues myself yet, but when I'm doing maps I'm rebuilding terrain a lot , And I mean a lot for example i put a tree down I rebuild , I cut a trail I rebuild, like every small thing I do I rebuild but I haven't encountered any problems doing it that way either so I'm not changing whats been working , but yeah it does take longer but in the end i feel its worth it.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.