Blutvor can't drop carried items

Story 9 (potentially other maps with goliath big guy)
Happened 100% of the time irrelevant of location and reload/reboot.
Thought it was game breaking due to carrying mission item (would have to repeat mission) but fixed it by killing him with allied cone/grenade fire and completing with other gang member.
Currently uploading video captures will update this thread when shareable.

The problem:
alt text
The fix:
alt text

Also happened with Pryska on mission 12, so couldn't use her for the rest of the match until another gang member arrived to break the barricade allowing her to extract.

True story. Happened to me with Vex on mission 11.

Maybe something to do with the aura, being heavy or something

I can confirm this as well, any heavy character the carry's an objective item ends up unable to drop it. The frustrating thing is you also can't drop or trade the item by any other means so it just leave you in a permanently stuck state. It would be nice if drop also worked in the inventory screen for such cases and just charged you the same amount of AP as using the skill or have another one of your gang trade them from the heavy.