Freesync/G-Sync stops working after Alt-Tabing <PTS 10.1> (still present in 12.7)

When you Alt-Tab out of the game and then back into it, adaptive refresh rate stops working. Monitor stays at max refresh rate regardless of the framerate. To make it work again you have to restart the game.

Video shows the issue:
https://streamable.com/38i8j4
(green is framerate, orange is monitor's refresh rate, 144hz monitor)

No other game has this problem for me.
It's a Freesync montior (AOC C24G1) with a Nvidia card (Geforce GTX 1070 - latest drivers) using Nvidia's "G-SYNC Compatible" function. Windows 10

If anyone is able to test if the same thing happens with a G-Sync monitor + Nvidia card or Freesync monitor + AMD card, please do.

last edited by Amynue

@Amynue Hello.
Thank you for the report.
Could you please send us your DxDiag file at snowrunner@saber3d.com?

To get it, display the Run dialog using Windows+R, type dxdiag and tap OK. Then, you could save your dxdiag as .txt file and send it to this dialog.

Also attach this link to the report.

WE will look into your case.

Problem still exists in 10.3

Still broken in 10.4

I also noticed that turning V-Sync on or off makes it start working, but after I alt-tab it stops working again.

Still broken in 12.1

Still a thing in 12.3

Still not working - PTS 12.4

Заранее извиняюсь,что пишу на русском.У меня похожая проблема,монитор 144 герц,стоит ограничение 1/2 от макс.количества фпс,т.е. 72,но только стоит свернуть или альттабнуть игру как фпс падает до 48(почему?).Только в этой игре такое происходит

Still bugged - PTS 12.7

I can confirm, still not fixed. FreeSync monitor (Acer VG240YU 75Hz) with Nvidia card (RTX 3070) using latest drivers and G-Sync Compatible mode.