Freesync/G-Sync stops working after Alt-Tabing <PTS 10.1> (still present in 15.1)

When you Alt-Tab out of the game and then back into it, adaptive refresh rate stops working. Monitor stays at max refresh rate regardless of the framerate. To make it work again you have to restart the game.

Video shows the issue:
Youtube Video

(green is framerate, orange is monitor's refresh rate, 144hz monitor)

No other game has this problem for me.
It's a Freesync montior (AOC C24G1) with a Nvidia card (Geforce GTX 1070 - latest drivers) using Nvidia's "G-SYNC Compatible" function. Windows 10

If anyone is able to test if the same thing happens with a G-Sync monitor + Nvidia card or Freesync monitor + AMD card, please do.

last edited by Amynue

@Amynue Hello.
Thank you for the report.
Could you please send us your DxDiag file at snowrunner@saber3d.com?

To get it, display the Run dialog using Windows+R, type dxdiag and tap OK. Then, you could save your dxdiag as .txt file and send it to this dialog.

Also attach this link to the report.

WE will look into your case.

Problem still exists in 10.3

Still broken in 10.4

I also noticed that turning V-Sync on or off makes it start working, but after I alt-tab it stops working again.

Still broken in 12.1

Still a thing in 12.3

Still not working - PTS 12.4

Заранее извиняюсь,что пишу на русском.У меня похожая проблема,монитор 144 герц,стоит ограничение 1/2 от макс.количества фпс,т.е. 72,но только стоит свернуть или альттабнуть игру как фпс падает до 48(почему?).Только в этой игре такое происходит

Still bugged - PTS 12.7

I can confirm, still not fixed. FreeSync monitor (Acer VG240YU 75Hz) with Nvidia card (RTX 3070) using latest drivers and G-Sync Compatible mode.

Please fix this already, this is still broken in 13.2

I'll add my voice to this.
(In my case, an official-G-Sync-module monitor (LG 32GK850G) running on an nVidia 1080ti)

Specifically, it seems the game will very easily switch into a "Borderless fullscreen" state, by alt-tabbing, but also sometimes just by happening to click the mouse while the game is loading, causing focus to shift before the game initializes the viewport.

I've made a habit of going into the graphics settings, switching to Borderless mode, applying, accepting, switching back to Fullscreen mode, applying, accepting, every time I alt-tab or launch the game, to try to force G-Sync to work.

Even then, I get the feeling it doesn't always "take".

Is it really this difficult to ensure that a true fullscreen viewport mode is enforced when the option is selected? I know this is a recurring and thankless issue with the likes of Unity Engine, but I would've thought this would be one clear benefit of having your own in-house developed game engine.

(Edit: I ask as a genuine question to developers - it seems like a LOT of modern game engines struggle near-endlessly with this issue, since some point in the past where true-fullscreen stopped being the default, and everyone switched to borderless-window as the default. So I wonder if it's some significant technical hurdle forced on developers by the Desktop Window Manager in later editions of Windows, or something along those lines?)

last edited by grimdanfango

Still not fixed in PTS 14.0
Please fix this.

@Amynue Hi, could you please help me. I have zero exhaust smoke since 14.2. Completely gone from all of the trucks.

@rendi88
He cannot help anymore, he's banned.

This is still broken in 15.1