FrogStompers release.

Name Map - FrogStompers
Description/Author Notes - Large trailing map, No logging.
Where it is set - Always wet Vancouver Island, British Columbia, Canada.
This is my first map and even with some glaring holes in my editing skills, I've decided to release this and move onto the next with more knowledge. Thanks to Nix for allowing me to use a couple of his models, much respect. Thanks to the guys who helped me test it and offered feedback.

Hope you enjoy and keep the rubber side down.

Features of Map:
➢ Garages - 4
➢ Trucks at spawn - 4
➢ Fuel Stations - 4
➢ Objectives - 0
➢ Lumber Points - 0
➢ Cloaks - 0

Updated June 5th
Link to Map - https://steamcommunity.com/sharedfiles/filedetails/?id=1407687979&searchtext=

8_1520398557673_20180305205837_1.jpg 7_1520398557673_20180305205512_1.jpg 6_1520398557673_20180305203557_1.jpg 5_1520398557673_20180305203119_1.jpg 4_1520398557672_20180305202901_1.jpg 3_1520398557672_20180305202258_1.jpg 2_1520398557672_20180305201648_1.jpg 1_1520398557672_20180305200048_1.jpg 0_1520398557672_20180225215938_1.jpg 0_1520398628941_20180305202430_1.jpg0_1520398960084_20180220215526_1.jpg

last edited by Fatboy

@fatboy A Canuk map! this is a must have. Nice pics, looks challenging. Nice work. Thx @fatboy .

This is a awesome map and a must have for me as i'm Canadian. Great work @Fatboy

Looks good! Looking forward to it!

Beautiful map......Nuff said,@Fatboy

It's very good. Earns The MudHappy Seal Of Approval. :the_horns:

Thanks for sharing!

last edited by MudHappy

@Fatboy
Needs more beaver... XD
#IMCDN

@mexican_420
Noted, more beaver in next map.

@Fatboy
You know I'm gonna get a beaver model into the game somehow because of that! lol

@mexican_420
Could make it an "Easter egg"
Map mission..Find the beaver.

@Fatboy
I was already doing that with a Sasquatch, but it may become a beaver hunt instead... 🙂

@mexican_420 said in FrogStompers release.:

@Fatboy
I was already doing that with a Sasquatch, but it may become a beaver hunt instead... 🙂

AH HA!!!

Took a ride on this for about an hour or more last night man , Nice Work.

New file available, sorry guys, found another problem and fixed it. This will be the last update. (hopefully)

I found a couple tiny water flaws in the first official release version. I didn't know you were still looking for them or I'd have pointed them out to you. Anyway...they're not really very noticeable as they were(or maybe still are). I'll see if I can find them again in the new version and report back.

last edited by MudHappy

Yes I found 3 flaws in the water...2 in the small creek and 1 in the river close to the middle crossings...hence the update.

Sucks because I can't just run my map and enjoy it..im constantly looking for flaws. Maybe I should have spent a few more hours polishing it.

It's good enough as is IMO. Doesn't have to be totally perfect looking to be fun.

I went back and found the spots I saw before. One is in that creek.
0_1520652188458_20180309174141_1.jpg
0_1520652724576_20180309174201_1.jpg

The other is in the small pond close to it. Got some anti-gravity water trying to climb the bank of it in one spot.
0_1520652127586_20180309174555_1.jpg
0_1520652745004_20180309174457_1.jpg

I also found a couple tears in the ground on the trail just a little ways to the east of the starting garage.

Front wheel is almost right on top of the first one. Second one is a little further down the trail in front.
0_1520652796506_20180309172427_1.jpg
0_1520652688489_20180309172450_1.jpg

last edited by MudHappy

i was wondering something. i ran the original map a few days before the release with another guy on here, he said he seen a tear in the road and i turned around to see where it was at. we was right next to each other and he said the tear was right by his wheel and said i was right on it. i couldn't see it at all. so...would it be possible for it to be a glitch its having where is is happening on one system and not on the other? maybe where the map had an issue when it was loading up? i know other mods have issues from time to time. didn't know if this might be one of them? it would be interesting if you had someone follow you im MP and see if they seen the same problems you do. just a thought.

Looks like your connection to Focus Home Interactive - Official Forums was lost, please wait while we try to reconnect.